GPIO config on 40-pin header for I2S2 - Pinmux configuration

Hi!

I am currently trying to setup my I2S2 port by changing the gpio pins function on the 40-pin expansion header. To do so, i have downloaded the spreadsheet and changed the needed pins function to I2S and then generated the dtsi files. I then proceeded to download on host computer SDK Manager and install Jetpack5.0 image on my host computer (in Ubuntu 18.04). Afterwards, i went in my folder to find Linux_for_Tegra in which there is the python script pinmux-dts2cfg.py file. I tried to run the command as it is written in the readme but i get this error :

How can i fix this?

Thank you and have a great day!

Loic

Could you try python2 instead of python3

Update:


still the same error…

Also, pad voltage seems to work fine

Hi loic.boileau,

Please use the dtsi file to dts directly. No need to convert it to cfg.
Reference this topic for more detail.

1 Like

Should I rename the 3 dtsi files before or just copy paste them to /bootloader/t186ref/BCT/ ?
I have found those dtsi files


but there is no dtsi file for gpio…

Also, afterwards do I just process to flash my Jetson Orin AGX using the SDK?

Thank you for your answers!

You should replace the dtb file generated by py.
You can know which dtb by check the Linux_for_Tegra/bootloader/flash.xml

Hi!

First, thank you for your quick answers!

So I went to see inside the flash.xml file and found out its the following tegra234-bpmp-3701-000-3737-0000.dtb :
image

So i then proceeded to convert it to .dts ton include my .dtsi :
(Jetson/Device Tree - eLinux.org)

but then i get this error while trying to recompile it :

What should I do?

-Loic

Update:

Following this website, the dts needs to be pre-compiled with c.

(linux - Device tree compiler not recognizes C syntax for include files - Stack Overflow)

After that it works nicely!

-Loic

Final Update:

I proceeded to reflash my Jetson, and tried to make the i2s2 port work by using the command : speaker-test -D hw:APE,1 and it didnt work…

But then I found this post and this time it worked… I dont know why it didnt last time.

Now the command works (verified with an oscilloscope) which means the i2s port is enabled.

-Loic

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.