GPIO not working?

Hi everybody.
I’m a big noob on all the GPIO and “raspberry” part. I just started experimenting.

The other day I tried to make a led blink, as explained in this tutorial

The main problem was that i didn’t have a transistor, so I tried followed a Raspberry Pi tutorial, and connected the led to the GPIO79 Pin (phisical pin 12) through a potentiometer, and then to a GND pin, without a using a resistor. It worked. The led was on, and its brilliance depended on the potentiometer’s position.
I then tried it connecting it to the 3v3, and the 5v outputs (the other side was always connected to the ground), and it still worked, untill i went too far with the potentiometer, and the led burned.

Today I repeated the experiment - initially i wanted to use the 5v to aliment a slightly more complex circuit, but nothing was happening, so i tried again with a led to make a test- but no light.
It didn’t work with GPIO79, 3v3, 5v, or any other pin.

I also tried to connect the led directly from 3v to the ground, then to 5v, expecting it at least to instantly burn, but nothing.
What am I missing?
Is it possible that while rebooting the NANO the 5v and 3v3 pins were deactivated? How is it possible to activate them, or to be sure they are actually working?

I just accidentally made a short circuit between pin 3 and pin 5 (5v and gnd), and the NANO shut down.

Hoping i didn’t burn anything, i think the 5v pin is activated… But still, apart from making a sparkles when i short-circuit it with a ground pin, nothing flows through my breadboard…

hello thomas.galliano,

you will also refer to Jetson Nano Pinmux for the default pin states,
there’s also a Python library that enables the use of Jetson’s GPIOs,
you might also check Topic 1030443 for some materials of using GPIOs.