Graphical regression in Elite Dangerous

starting from driver 525 there’s been a graphical regression in Elite Dangerous’ HUD, as shown here

nvidia-bug-report.log.gz (3.1 MB)


I am also getting this - usually within a minute or two of starting.

I am also experiencing this issue on Driver 530.41.03

Interestingly, I’m only seeing this with 530. Branch 525 is still fine for me.

I’m also seeing this on 530. Downgrading to 525 does seem to fix things. This is on both a mobile 1650 and my RTX 3070.

1 Like

I accidentally hijacked a thread previously mentioning this issue: VRAM Allocation Issues - #22 by thesysadminfromhell

Downgrading to 525 is fine, which has to be done in Arch Linux as it does not have separate packages for the different branches for the Nvidia driver. 530.41.03 is currently the version of the driver in the New Feature branch, which often will bug out at times, though I do appreciate being able to easily access the package as it allows us to test and provide feedback.

Edited to add: I must correct myself!

If anyone here is using Arch and wants the latest production branch nvidia, the AUR has the packages up to date in the form of:

  • nvidia-525xx-dkms
  • nvidia-525xx-utils
  • lib32-nvidia-525xx-utils
  • lib32-opencl-nvidia-525xx
  • libxnvctrl-525xx
  • opencl-nvidia-525xx
  • nvidia-525xx-settings

This should just about cover most common use cases. Other files can be found through searching for nvidia in the AUR and grepping for 525xx.

We can confirm that this is a NVIDIA driver regression. This is tracked in NVIDIA bug 4127336.
Can someone confirm that setting the env variable __GL_b5f2b3=0xFFFFFFFF makes the problem go away?


With that set, I was able to pass the surface operation training without any obstructing polygons/textures getting in my way.

This has also stopped Resident Evil Village from crashing and showing very occasional black textures.

For me at least - after experimentation, env variable on or off I’m still getting the glitching. (Running with an RTX3080 with driver 530.41.03-17 on Arch)

__GL_b5f2b3=0xFFFFFFFF fixes ED for me with 535.

__GL_b5f2b3=0xFFFFFFFF ED works with 535.54.03.

Just clone related git and change PKGBUILD - put there any version avail from nvidia website, that will do all. One should use nvidia-dkms though, because other versions are pre-build for current kernels at that moment.

Having just updated to version 535.54.03-2 - Setting this __GL_b5f2b3=0xFFFFFFFF - now works for me, no glitching at all!

The problem disappears with env variable referred in this post.

Glad to hear that this unblocks you!
The proper fix is present in our latest developer beta driver:

and will show up in our next r535 release and more recent branches
In the meantime the environment variable is a viable workaround.