Grid K1 & Cuda

Hi, I have a Nvidia Grid K1 card, in a Dell R730 Server, using with ESXi 6.5 vGPU to a Windows Server 2016 VM, using K180Q mode.
I am using the latest driver pack: NVIDIA-vGPU-kepler-vSphere-6.5-367.123-370.17, and using 370.17_grid_win10_server2016_64bit_international.exe in the Windows Server 2016 VM.
Everything looks correctly installed. But…
I am trying to use applications which utilise CUDA, so I am trying to install a CUDA driver, (I have tried CUDA version 7.5, 8 and 9) but when I try and install any of these CUDA drivers I just get the massage that no compatible hardware was found.
Any ideas please?

Understood, thanks for the info. So I just changed it to do a straight passthrough (not vGPU) to the VM, installed the latest driver, but when trying to install the CUDA 8 driver, I still get the "no compatible hardware was found" message.
What am I doing wrong?

OK, thanks for your reply, I have a couple of questions:

  1. Is CUDA 8 the last version that can be used with this K1 (I cant install or use CUDA 9, whihc is what I would prefer) ?
  2. For CUDA 8, I can just install the driver package "370.17-quadro-winserv-2016-64bit-international-whql.exe" and CUDA 8 should work?
  3. I would like to use this K1 card for some Mining (I know its not veru profitable, but it is spare currently, and I wanted to test), but whatever I use complains that it can’t see any CUDA devices.

Kind regards.