Grid K1 & Cuda

Hi, sorry if this is the wrong forum, but there’s a lot of different bits to this issue.
I have a Nvidia Grid K1 card, in a Dell R730 Server, using with ESXi 6.5 vGPU to a Windows Server 2016 VM, using K180Q mode.
I am using the latest driver pack: NVIDIA-vGPU-kepler-vSphere-6.5-367.123-370.17, and using 370.17_grid_win10_server2016_64bit_international.exe in the Windows Server 2016 VM.
Everything looks correctly installed. But…
I am trying to use applications which utilise CUDA, so I am trying to install a CUDA driver, but when I try and install and CUDA driver I just get the massage that no compatible hardware was found. I have tried version 8 and 9.
Any ideas please?

CUDA 8 GA2 requires a r375 or newer driver. Your 370.17 driver pack won’t satisfy this requirement.

You should:

  1. Use the latest GRID driver for your GPU. (seems to be the case here)
  2. Use a CUDA version compatible with that driver - which would be CUDA 7.5 for r367/r370 - and no need to install the driver provided by the CUDA installer - use the GRID driver
  3. Use the largest available GRID profile, which effectively assigns an entire GPU device (of the 4 that are on a K1) to a single VM. (K180Q should meet this requirement)

Under that scenario, CUDA should be usable in the VM.

I would encourage you to file such questions at the gridforums

http://gridforums.nvidiia.com

Hi, thanks for the info, but looking on the Nvidia Drivers site, this is the latest driver:

NVIDIA GRID VGPU SOFTWARE RELEASE 367.123/370.17
Version: 370.17 WHQL
Release Date: 2017.12.14

Im ultimately looking to install CUDA 9, which doesn’t look possible?
Regards.

Yes, I already mentioned that your driver pack appears to be the latest driver offered. I would agree that it doesn’t look possible. As I already mentioned, it looks like CUDA 7.5 is the latest possible CUDA toolkit using that driver.

Got it thanks. I just tried to install CUDA 7.5, but got the same “no compatible hardware was found” message.
I’ll create a new thread on the Grid Forums.

Regards.

I’m not surprised that the installer is reporting “no compatible hardware found” message. This can happen in normal/legitimate setups where the installer simply does not recognize the GPU, perhaps because it is too “new” (compared to when the installer was created). You should still be able to proceed with a CUDA install even though you have received that message.

After that, CUDA should work.

Hi, ah, OK, thanks for the reply. I just found that the reported CUDA version 8 in the Nvidia System information:

https://drive.google.com/file/d/1MoKUoCXS1mySb6euu1Cu8hMKbyezxRd2/view?usp=sharing

Does that indicate I should install CUDA 8 (I see there are two CUDA 8 versions you can donwload)?

Regards.

The original CUDA 8 (GA1) release should work with R367/R370 drivers. The CUDA 8 GA2 release requires R375 drivers. You can try to install the original CUDA 8 release :

https://developer.nvidia.com/cuda-80-download-archive

again, keep your existing driver. Do not install the driver offered by the toolkit installer.