GRID Xorg ?

Hi all ~

we are trying to get a GRID instance up and running for our OpenGL apps,
but must be missing something in the setup…

HOW to set up a proper Xorg.conf for GRID rendering???
After the nVidia GRID driver installs, the system tries to load the GRID card as a display (:0) on boot up.

So when a remote client connects (eg VNC) we do not get a hardware-accelerated window context – VNC does not see the GRID and GLXgears complains that extension GLX missing on display :1
We are on Ubuntu 14.04, no virtualization.

Also, is the use of virtualGL.org typical?

thanks for any help you can provide!

best,
_n_polys

Hi,

I’m basically in the same situation. Trying to get GRID K2 to run on a non-virtualized bare-metal server environment. The server has an integrated Matrox G200 chip and K2 card. I can get Xorg to start (but not display anything) by using BusID and Option “AllowEmptyInitialConfiguration” “true” (as there is no physical display connected), but connecting with VNC gives me the same “GLX missing …” thing as you also see.

Any help is more than appreciated!

I’ve tested with latest production drivers as well as with “NVIDIA-Linux_x86_64-368.09” beta drivers.

Best regards,

PM

Another ‘me too’ here also.

Trying to get a K2 to run non-virtualised on a bare-metal Dell R730. X runs fine with the open source Nouveau drivers but it’s using software 3D by the looks of it. Switching to the NVIDIA drivers completely borks X - the server starts but I get the sad face ‘Oh no - something went wrong’ screen. I’ve done all the tweaks (BusID, AllowEmptyInitialConfiguration etc), have tried several driver versions and have tried RHEL6.8 and 7.2 but to absolutely no avail.

I’m beginning to think that it’s just not possible - these are designed as GRID cards after all, so that might be fair enough. Getting desperate so the next idea is to try a more ‘desktop-y’ distro like Ubuntu, which is far from ideal (we’re almost exclusively RHEL here) but might prove the point either way.

Cheers,

Jack