GT440 fan speed can not be lowered below 50%

Hi,

Today I installed a new Asus GT440 into my PC

installed Linux driver: 304.60
Linux distro: Fedora 13.

added:
Option “Coolbits” “4”
to my xorg.conf, so nvidia-settings shows the “Enable GPU Fan Settings” in
the Thermal Settings. The fan speed percentage defaults to 50%.

Increasing it and then clicking “Apply” works: the fan runs faster.

Decreasing it (e.g. to 40%) and clicking “Apply” does nothing: the slider returns to 50%.

I’d love to decrease it, the card runs at 30-34C with the fan at 50%
(which is quite noisy).

I have scoured the web for answers, and nothing works (did not try
the “flash gpu bios” (?) suggestion that I saw in a few places).

Is there any way to troubleshoot this?

I downloaded the nvidia-settings source, I’m perfectly happy to
do any required coding to fix this…

thanks,

Patrick

The thread list at https://devtalk.nvidia.com/default/board/98
shows that there is 1 reply (so presumably 2 now), but it isn’t shown (?)

Edit: a few people with the same problem:
http://ubuntuforums.org/archive/index.php/t-2048202.html

The fix suggested there involves flashing the card’s BIOS though,
which I am not (yet) prepared to do…

Patrick

I’d really appreciate it if someone from nVidia would give some more
info (if possible).

It looks like this enforced limit happens either at the driver level, or the card level.

For now I’ve connected the graphics card fan to a spare fan connector
on the motherboard, with a 120 Ohm resistor in one of the wires to slow it down.
It’s much quieter now, with no significant effect on the GPU temperature :-)

Patrick