GTX 4080: second monitor freezes

According to the changelog a bug was fixed in 535.86.05
* Fixed a bug that prevented displays from refreshing when using an
NVIDIA PRIME Display Offload sink.
I suspect this was reintroduced in your current 535.113.01
Can you possibly downgrade the driver to a working one?

Ok I can try that.
Just to be sure I understand correctly, you mean that I should downgrade to 535.86.05, right? Can you point out where to download old drivers?

Rather try another driver that you can just select from “Software&Updates” first.

You mean one of these?

Or one of the other available ones at this website?

The first one, try “metapackage from nvidia-driver-525 (proprietary)”

Same issue:
https://forums.developer.nvidia.com/t/external-monitor-freezes-when-using-dedicated-gpu/265406?u=generix

1 Like

I reverted back to 525 as instructed by ‘generix’.

Maybe a minor detail, but now when I call nvidia-settings I don’t see the information of my hardware as it was shown when I had the latest drivers:

Let’s see, I’ll report back after some flight hours.

Thanks, I’ll try and report back.

Would you advise on following this tutorial? It mentions a ‘method of installing NVIDIA drivers involves using the NVIDIA CUDA repository, which is frequently updated and supports Debian, Ubuntu, RHEL, and other popular Linux distributions.’ Would it make any difference to this case?

Nvidia-settings not showing the gpu details is a bad sign, something went wrong downgrading the driver. Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (138.3 KB)

Due to using the runfile installer you now have a mix of 535 and 525 driver versions, which doesn’t work. Please try this:
In software&updates, switch to the nouveau driver. This should remove all nvidia packages. Then run the runfile installer for 535.113.01 with option -b, immediately afterwards run it again with --uninstall option. This should remove all nvidia driver files. Then use Software&Updates to switch to the 525 driver and reboot. Please create a new nvidia-bug-report.log afterwards.

Thanks. I tried switching to nouveau driver before, and I think I did something wrong because it ended up badly… so this time I want to confirm so I don’t screw it again. This would be the sequence, can you confirm?

  1. In software&updates, switch to the nouveau driver. No rebooting.
  2. run the runfile installer for 535.113.01 with option -b. No rebooting.
  3. run the runfile installer for 535.113.01 with option --uninstall. No rebooting.
  4. use Software&Updates to switch to the 525 driver. Reboot

So I have to reboot only after step 4, right?

Correct.

Thanks for the confirmation. I will try.
In the meanwhile, maybe it is worth mentioning that the problem seems to have gone. I will try your suggestion anyways to have my system in order.

1 Like

Hello @generix and @j22gim
I have similar problems, and I’ve posted them here.
I did:

  1. In software&updates, switch to the nouveau driver. No rebooting.
  2. Downloaded the 535 driver and made it executable (chmod +x)
  3. run the runfile installer for 535.113.01 with option -b. No rebooting.
  4. run the runfile installer for 535.113.01 with option --uninstall. No rebooting.

Now I have the problem that software&updates will not let me check any other driver to install:


Any thoughts?

You shouldn’t have done that, it was only meant for @j22gim’s system to clean up runfile installer issues not related to the bug.
I guess Ubuntu meanwhile introduced an additional check in Software&Updates to detect an earlier runfile install. Please try to install it manually running
sudo apt install nvidia-driver-535

PS: rather stick to the other thread as there’s already amrits of nvidia active.

1 Like

Ok I have tried and found some obstacles, I did not complete even the 2nd step. I report here to avoid messing up my system again.

  1. switched to noveau. Done.

.
2) run the runfile installer for 535.113.01 with option -b. No rebooting.
The file I used is NVIDIA-Linux-x86_64-535.113.01.run. After checking that it is executable, I used this command in the terminal:
sudo ./NVIDIA-Linux-x86_64-535.113.01.run -b

.
To which I found this error:

ERROR: An NVIDIA kernel module 'nvidia-drm' appears to already be loaded in your kernel.  This may be because it is in use (for example, by an X server, a CUDA program, or the NVIDIA     
         Persistence Daemon), but this may also happen if your kernel was configured without support for module unloading.  Please be sure to exit any programs that may be using the        
         GPU(s) before attempting to upgrade your driver.  If no GPU-based programs are running, you know that your kernel supports module unloading, and you still receive this message,    
         then an error may have occurred that has corrupted an NVIDIA kernel module's usage count, for which the simplest remedy is to reboot your computer.

After pressing OK:

ERROR: Installation has failed.  Please see the file "/var/log/nvidia-installer.log" for details.  You may find suggestions on fixing installation problems in the README available on     
         the Linux driver download page at www.nvidia.com.

nvidia-installer.log (1.3 KB)

I have seen many posts about this but again, I don’t want to try anything crazy. I really need my system up and going.

I did not reboot.

This is expected on that step, just ignore and continue with the next step, --uninstall.
The last step now has to done manually due to changes in Ubuntu’s software&updates
https://forums.developer.nvidia.com/t/gtx-4080-second-monitor-freezes/270374/22?u=generix