Having an issue applying the nvidia rtx gi patch

https://answers.unrealengine.com/questions/1004508/having-an-issue-applying-the-nvidia-rtx-gi-patch.html

this are the errors when I check the patch in the windows prompt by the command: git apply --check RTXGI-NvRTX4.26.1.patch

error: patch failed: Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.cpp:272
error: Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.cpp: patch does not apply
error: patch failed: Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.h:32
error: Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.h: patch does not apply
error: patch failed: Engine/Source/Runtime/Renderer/Private/IndirectLightRendering.cpp:342
error: Engine/Source/Runtime/Renderer/Private/IndirectLightRendering.cpp: patch does not apply
error: patch failed: Engine/Source/Runtime/Renderer/Private/RayTracing/RayTracingLighting.h:14
error: Engine/Source/Runtime/Renderer/Private/RayTracing/RayTracingLighting.h: patch does not apply
error: patch failed: Engine/Source/Runtime/Renderer/Private/SystemTextures.h:11
error: Engine/Source/Runtime/Renderer/Private/SystemTextures.h: patch does not apply

1 Like

facing the exact same problem. No solution found on the internet. Please help.

same here please help

This worked for me “open the patch file in Notepad++, go to Edit->EOL Conversions, select Unix (LF), save the file, and then try to apply the patch.”

https://github.com/NVIDIAGameWorks/RTXGI/issues/35