HDMI Issues on TX2 Custom Carrier Board

We are not getting HDMI display on our custom carrier board for Jetson TX2.
The OEM design guide was followed exactly for developing the carrier, and verified against the design of the NVIDIA Jetson TX2 Developer Kit.

System configuration combinations tried till now:

  • Jetpack version 3.1, 3.2, 3.3
  • Monitors used: Sony Bravia and Dell S2240L
  • Just for experimentation we used TX1 also

Steps taken by us for debugging this till now:

  • Followed the debugging tips mentioned in https://elinux.org/Jetson_TX2/r28_Display_debug.
  • Made the UART0RTS and UART1TX pins floating, as was mentioned in many of the forum posts.
  • Tried enabling/disabling the 5V0_HDMI_EN block in tegra186-mb1-bct-pmic-quill-p3310-1000-c04.cfg, according to the Platform Adaptation Guide.

dmesg log, Xorg.log and EDID contents (after the monitor is connected), are attached in this post.

Observations from the above mentioned debugging activities:

  • HDMI I2C communication is happening without any issues, this is evident from the fact that we are able to read the EDID and can verify the monitor details.
  • We get the display on monitor in only one case, with the resolution set at 1280x720. However, the display is scrambled and unstable. Screen flickers and then dies off. Please refer the attachments for the screenshot of the display in this condition.
  • In all other resolution cases, there is no display, with the following message on monitor
    Unsupported signal. Please check device output.
    No signal.

dmesg.log (63.9 KB)
Xorg.log (150 KB)
edid.log (768 Bytes)

I saw the mode just changed from 1080p to 720p.
Do you change this mode manually?

22.819] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0"
[    23.632] (--) NVIDIA(GPU-0): SONY TV (DFP-0): connected
[    23.632] (--) NVIDIA(GPU-0): SONY TV (DFP-0): External TMDS
[    23.632] (--) NVIDIA(GPU-0): SONY TV (DFP-0) Name Aliases:
[    23.632] (--) NVIDIA(GPU-0):   DFP
[    23.632] (--) NVIDIA(GPU-0):   DFP-0
[    23.632] (--) NVIDIA(GPU-0):   DPY-0
[    23.632] (--) NVIDIA(GPU-0):   HDMI-0
[    23.632] (--) NVIDIA(GPU-0):   DPY-EDID-66599cf4-ef56-893f-8f5f-8e1ca3dfe91a
[    23.632] (--) NVIDIA(GPU-0):   HDMI-0
[    23.757] (--) NVIDIA(GPU-0): SONY TV (DFP-0): connected
[    23.757] (--) NVIDIA(GPU-0): SONY TV (DFP-0): External TMDS
[    23.757] (--) NVIDIA(GPU-0): SONY TV (DFP-0) Name Aliases:
[    23.757] (--) NVIDIA(GPU-0):   DFP
[    23.757] (--) NVIDIA(GPU-0):   DFP-0
[    23.757] (--) NVIDIA(GPU-0):   DPY-0
[    23.757] (--) NVIDIA(GPU-0):   HDMI-0
[    23.757] (--) NVIDIA(GPU-0):   DPY-EDID-66599cf4-ef56-893f-8f5f-8e1ca3dfe91a
[    23.757] (--) NVIDIA(GPU-0):   HDMI-0
[    43.748] (II) NVIDIA(0): Setting mode "NULL"
[    43.864] (II) NVIDIA(0): Setting mode "HDMI-0: 1280x720 @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}"
[   208.189] (--) NVIDIA(GPU-0): SONY TV (DFP-0): connected

Does same display work fine on our devkit?

No, it was not changed by us. This log is for Sony Bravia monitor, and the maximum resolution supported was 720p in this one.

Yes, it works fine with the Nvidia devkit

We found the problem causing the HDMI display to be scrambled. The problem was with the capacitance bank on the HDMI trace lines near the SOM on the schematic. We figured this out after comparing the HDMI clock signal with that of the Nvidia devkit. The clock signal in our board was not clean.

Also for us, above mentioned modification is not required.

Glad to hear it is working.