HDMI not being detected after kernel upgrade: Linux Mint Tessa 19.1, kernel 4.15.0-48-generic, nvidi...

Everything was working perfectly, and I could use my 32 inches tv connected into the HDMI port, but since yesterday, when the kernel got updated, my TV shows no signal and I can not use it anymore.

Attached is the nvidia-bug-report.log.gz I have just generated using sudo nvidia-bug-report.sh
nvidia-bug-report.log.gz (544 KB)

The logs look like your HDMI port is connected to the integrated intel GPU, not the Nvidia GPU so the Nvidia driver is not involved.
Nevertheless, nothing is detected on the HDMI port, does downgrading the kernel fix the isuue? This might also be just a flakey connector or cable, did you try to move the plug a bit or change the cable?

Addendum: also check if the connector at the TV is properly seated and is working (does a different device work?).

Thank you for your answer.

This is a laptop with a single HDMI port, so it would be nice to know how to “force” it to use nvidia instead of intel. Do you have any idea?

I tried changing the port on TV (it has 2 ports) and also tried replacing the cable with another one I know for sure is working on another tv, and it didn’t work too.

No, this is an Optimus notebook and in your case, both the internal display and the HDMI port are hardwired to the intel gpu. The nvidia gpu doesn’t have any outputs, it just renders the picture and then copies it to the igpu’s framebuffer for output. So you can only see if downgrading the kernel makes the hdmi port work again, otherwise the connector seems to be broken.

I am going to try the downgrade path… thank you

having a similar problem on ubuntu 19.04 and i am on an optimus laptop. a razer blade 2017 to be specific so it has the gtx 1060. hdmi stopped working after i upgraded from 18.10 to 19.04

dackdel, on your hardware this is probably a completely different issue, with GTX1060, the HDMI ports are often connected directly to the nvidia gpu. I guess you’re running into a known GDM/Wayland bug. Try replacing GDM with lightdm:

sudo apt install lightdm
sudo systemctl enable lightdm

after entering enable lightdm

Synchronizing state of lightdm.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable lightdm
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

is this ok?

also towards the end of sudo apt install lightdm in the cli there was a pink dialouge box that prompted me to select a default between gdm and lightdm and i selected lightdm. is that ok?

thank you for your reply.

Should be ok.

Thank you so much! This worked like magic. So I understand this is an existing prevalent problem with “gdm/wayland”