Hide Nvidia tray icon

Hello,

We are trying to hide the nVidia Tray icon and the shell icon (right click desktop). I can disable it on the server through the application, however that’s user based.

With RegShot I’ve found out it uses the keys:
HKCU\Software\NVIDIA Corporation\NvTray\StartOnLogin
HKCU\Software\NVIDIA Corporation\Global\NvCplApi\Policies\ContextUIPolicy

When disabled they have a value of 0. However both using these keys with value 0 to a users profile does not hide them, nor does adding them to HKLM work.

Our users get very confused (I know right) with a new icon and would like it to be hidden. Can you tell me another way to hide it for everyone?

Thanks.

Hi,

could you please try the following for the NVTray Icon:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvlddmkm\NvTray]
"StartOnLogin"=dword:00000000

Regards

Simon

Great, the tray icon is hidden now. However the "nView Desktop Manager" still shows when users right click the desktop. What way should we use to go around that?

I’ve already tried removing the option from the registry:
HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\NvCplDesktopContext

However after a reboot it’s back.

Hi

I covered this a while back, here’s a link to my post, it should do what you’re after …

https://gridforums.nvidia.com/default/topic/1190/restrict-nvidia-control-panel-setting-changes-via-group-policy-or-registry-/?offset=2#4407

For persistence, just use a GPO.

Regards

Ben

Thanks for sharing Ben.
Nice idea to just hide :)

Regards

Simon

Is there anything else you can do to hide the tray Icon in driver version 391.81? The registry key above does not seem to work. This is causing a major issue at the moment where the task tray icon is launching with Autodesk products. It does not close when the user exits the virtual application. Leaving the session open and causing interruptions when they cannot launch the app again because the session is still running.

If anyone is having issues with removing the Nvidia Tray icon from the notification area follow the steps below. I must admit that I don’t fully understand the consequences for doing this, so please make a backup to your PC before attempting this just in case something goes wrong!

Anyway registry edits to NvTray don’t seem to work with the newer drivers. After doing some fiddling on my PC I found if you kill the process “NVDisplay.Container.exe” and hover your mouse over the icon it will go away.

You can find this file at:
"C:\Program Files\NVIDIA Corporation\Display.NvContainer\NVDisplay.Container.exe"

I simply renamed "NVDisplay.Container.exe" to "NVDisplay.Container(disable).exe"

**NOTE: you will have to kill "NVDisplay.Container.exe" in task manger before you can rename the file

Reboot the PC and the tray should be gone.

Again I want to say that I don’t know if this will have any other impacts on the operation of the NVIDIA GPU but I haven’t had any issues with Windows or playing games.

I didn’t find a solution when googling so wanted to make this reply to hopefully help someone else out.

I am using Windows x64 with the latest NVIDIA Drivers and April Windows updates.