(false positive) license error after upgrading to Nvidia grid driver 451.48

After upgrading my golden image to Nvidia grid driver 451.48 I notice now that every user receives a balloon pop-up stating "NVIDIA license not present. However, this message is false since when you click the balloon and look at the license manager you see that the license server is present and valid.


addendum: this happens when the user logs in and the system tray icons are loading. Perhaps this could be some sort of timing issue where the balloon checks too fast.

Is there any way I could maybe remove the system tray icon completely as a workaround ?

Hi Profundido

If you’re sure it’s getting a license, then you can create and set the following Registry Key to disable the Pop-up:


Key = DisableSpecificPopups
Value = 1

Use a GPO to set the Key so it’s easy to track and revoke if needed.



Known issue. Will be fixed in the next release. Be aware that this is only a "cosmetic" issue as the VM is properly licensed. As workaround you can use the Regkey mention by MrGRID


Thx guys. I will try the workaround. I noticed indeed that functionality wise there are no problems but I cannot release a build update in which this balloon message happens since it will rain tickets with end user questions about it the next day.

By the way, I had been wanting to disable the Nvidia system tray icon all together already before this license error because:

  1. The license management console seems not to be multi-user aware. If I click it -even as admin- another end user on the same Citrix server will typically get the actual management console to pop up in their Citrix Xenapp session where I won’t get to see it (unless I’m the only user on that server)

  2. End users are typically curious and tend to click this system tray icon in their Citrix Xenapp session, causing popup’s for someone else on the server to happen.

Update: I set the reg key manually in the build (since it’s Hkey local) rather than through GPO and rebooted the machine but upon next login I saw the error again. This doesn’t seem to work. I rebooted the server twice to make sure my test was valid and doublechecked the key:


Hi Profundido

I’m using the setting I listed in some of my deployments with vGPU 11 and it does work. Not sure why it’s not working for you though. Looks like you have it configured as required.

Just for reference, there’s a list of useful vGPU registry settings available from here, including the removal of the license component from the Control Panel:




Thanks. That’s a useful overview of available switches.

I had already tested using the fix from the other 2year old thread where we remove the icon completely and after testing that part seems to work. First login after rebooting I still saw a short flash after which the icon dissappeared but subsequent logins don’t see anything at all.

I think I’ll use that for now as full workaround so I can release this build and experiment with other switches later.

We are seeing the same issue as well and reg key to hide notifications does not work. NVIDIA, can you guys release some sort of intermediate client patch or workaround as its generating support calls?

This exact value below in a build update of your golden image (or deploy through gpo) did the trick for me:


Reboot after implementing or make your build go live and then test with multiple logins from different users

I have this set under current user SOFTWARE\NVIDIA Corporation\NvTray StartOnLogin

This seems to shorten duration of the message. It is still there, however, for the first user to logon to the machine.

Havent tried disabling tray for the entire machine yet.

Update: After I put my build in production today I too noticed that the error message still appears very briefly for the first person that logs in to that server (not for subsequent user logons) but since the icon is immediately removed it’s harmless now. People don’t have the time to even try clicking on it.

For me personally that’s sufficient as a workaround. Note though that this is still using the workaround of completely removing the system tray icon for everyone. The original reg value that is supposed to only prevent the balloon popup message (without removing the system tray icon completely) doesn’t work for me either.


we have the same error in our environment. Please get the fixed version released quickly.
I opened a support case about this and nobody told me that this is a known issue.


for anyone that follows this: I can confirm that since the latest drivers (452) that I just installed solved the problem for me. There no more license error popups during first logon on a server.