Nvidia License server 5.1 and Citrix provisioning Services 7.15 - problem wit issueing client licens


I have a fully working VDI environment. XenDesktop 7.15, PVS 7,15m, latest GRID release with latest license server. Two Tesla M60 cards running on XenServer 7.3.

The problem is that Nvidia license server does not work good with PVS / MCS master image. Very randomly windows10 clients will get their license. I use the full Demo license för PoC right now.

If I create a maintenance version of the vdisk (pvs vdisk in read/write mode ) and do wathever editing i want, close down the image and run it in "production", All the 16 VDI,s will get their license. If I reboot them they will not get any.

It does not matter how much I reboot, I NEED to open master image in new version again and do any change, close it down and then It will work. That is no good…

I took me a while to see that pattern. I have currently the settings in registry and tried the nvidia control panel way aswell… Seems like a fix is needed for this. We need this environment in producation soon…
I should say I use PvD . (Personal Vdisk) for static desktops in XenDesktop.

Please advice!!

– Fredrik Thörnberg, AceIQ

Hi ftho,

you shouldn’t license you master template otherwise you run into the issue described. Just use the Registry settings in a GPO for your VMs and that should do the trick. Unfortunately there seem to be an issue with PvD so that Flexera treats it as a violation.
This is already under investigation from Flexera…



Hi Simon,

Thank you, I will try that. Cannot see anything about that information anywhere.

Regards, Fredrik

Hi Simon,

So it worked for a couple of days and reboots. Now back to same issue.

Are you telling me that GPO with regsettings yould work every time, but because I use PvD this problem occours?

Any workaround ?

// Fredrik , AceIQ Sweden

Hi Fredrik,

I still assume your master is not 100% clean. Please make sure there are no files under:
C:\Program Files\NVIDIA Corporation\Grid Licensing\ also check for hidden files in this path. If there are files, delete them and create new VMs from your template.



Try this workaround if you are still experiencing this timing issue: