How do I FIX "not enough disk space to install" Issue for SDK manager 1.1.0.6343

SDK Manager keeps getting error “There is not enough disk space to install the selected SDK.” I have already downloaded all the files and I was trying to do an offline install, but I keep getting the error.
Question: What steps can I take to resolve this issue? Do I delete the files from /sdkm_downloads directory? What VARIABLE in the sdk manager is used to determine if there is enough disk space to do install?

I was trying to install Jetpack 4.4

Most of that I cannot answer. What follows is basically random information which might help…

During an install a manifest is downloaded. From this other packages are downloaded, and this creates content in the sdkm_downloads. If you delete those files the only result will be downloading them again (assuming you have internet access). Sometimes this is good as it can verify no download was truncated/corrupt.

The actual active content, for cases where content is used on the host PC, is unpacked somewhere under “~/nvidia/nvidia_sdk/”. You can delete this content if you think something on the host side went wrong. This would again result in downloading and unpacking some content again.

The subdirectories of “~/nvidia/nvidia_sdk/” are named after the module/carrier board combination. The “P2888” is for Xavier. If you’ve attempted to install/flash that, then there will be a subdirectory named after that and the JetPack release number. Within this is a “Linux_for_Tegra/” directory, and this is the “driver package” (the software which understands a Jetson in recovery mode).

During a flash the host PC needs a lot of spare space. The entire file content which will be flashed is unpacked into the “Linux_for_Tegra/rootfs/” directory. Depending on release, this might take up about 4GB of space.

Then a “raw” image (a bit-for-bit exact copy) of the future root filesystem is created as “Linux_for_Tegra/bootloader/system.img.raw”. If your partition is 30GB, then that file will take up 30GB.

Then a “sparse” (I call it a poor man’s compression) version of system.img.raw is created as “Linux_for_Tegra/bootloader/system.img”, and this file is probably a few GB in size.

Miscellaneous smaller images and files are copied around depending on options in the command line. Overall, if JetPack/SDKM is already installed and rootfs is unpacked, I would not recommend starting a flash without having at least 35GB of space. If SDKM has not already unpacked content, then you probably want at least 40GB of host PC space (just a rough estimate).

If you want to see how much disk space you have available in your home directory, and see the filesystem type (which should be “ext4”), then run command “df -H -T ~”.

@blue_redd, what is the output of
dh -h
it might require merely 50 gb to get through for the destination “Jetson installation image” at least 32gb sdcard is not large enough

I increased the size of the disk, and issue resolved. Now flashing jetpack 4.4 keeps failing at 99.97 % completion. Im trying it manually using ./flash.sh instead of sdkmanager…

Are you running on a VM? It is quite common for similar hangs/fails. The Jetson will disconnect and reconnect multiple times during a flash, and a VM tends to not reconnect correctly. There could be other reasons, but knowing if a VM is used is the first question.

reasons for failing at 99% could vary;
when I was getting the issue I released space at /root/, /tmp, /install_target, and installation got through;
you may try wiping downloaded files and folders and system.img, then repeat steps;
you may also monitor space state during the installation with
watch exec df -h

Hey, i am encountering the same problem with the missing disk space while using a VM with more than sufficient disc space. Is flashing a jetson not possible with a VM at all or what are my options?
I am using the VM to get a ubuntu machine, because my PC is running on Win7. Is there an alternative way to flash my jetson with Windows?

You have to use a Linux PC for flash (or a VM if that VM is configured correctly, but that can be a story all its own). The space needed would be at the location of running the software. Specifically, what do you see from “df -H -T ~/nvidia/nvidia_sdk”?

I increased the size of the VM to 200gb that fixed it, but now im running into the Problem with the Jetson not being recognized by my PC when in force recovery mode. Thanks for your help though, i guess i will find a linux machine somwhere.

…this is likely the VM losing USB to the parent o/s. Every VM is different, and probably different releases of the same VM are also different for configuration. All I can suggest is to check documentation to see how to always send the recovery mode Jetson for control by the child VM instead of parent o/s. This may not be a problem if you are an expert in the VM already, but native (or dual boot) is generally easier.

SDK installer indicate 23G+7G+6G for diskspace
but a better guess is between 50G and (a working case is close to) 65G (on top of basic ubuntu system size).

1 Like