Jetpack 4.4 space estimation issue

I am running jetpack from a tiny laptop which has small disk;
with 4.3 version It would take sdcard 32gb to get through the flashing; also it would take extra 16gb usb-flash card;
with 4.4 it would say that the disk is full even if I am using the same sdcard & usb-flash; even with new fresh ubuntu installation having 15 Gb free space, and even when I exclude host installation and select only jetson installation;
Tried offline/online install. tried reinstalling OS Ubuntu.
What is taken by the sdk as for disk estimation? what is the minimal required amount of space required since 4.4 version?
Thanks

Hi Andrey,

with 4.4 it would say that the disk is full

Can you please clarify whether this is host disk full and you couldn’t flash, or Jetson disk full and you couldn’t install all target components?

  • If this is host disk full, please separate the Jetson install to two phases.
    • Phase one, only flash Jetson device. After flashing, uninstall and remove the downloaded files free disk space.
    • Phase two, install target components without selecting “Jetson OS” group.
  • If this is Jetson disk full, it is caused by default size of the flashed image is around 15GB. We are looking into the issue. For now, please use a workaround to manually flash. For example,
    sudo ./flash.sh -S 29GiB p3448-0000-sd.conf mmcblk0p1

Hi EdwardZhou,
Thank you for your response.
The pop up window stating about fullness of the disc pops up If to select both chheckboxes “download to path so and so” & “install image to path so and so”. As Host Installation package is not a concern for me, I mount sdcard 32 gb & 16 gb usb-stick for these two parameters typically. Then I change ownership for these storages and write permissions so that sdkmmanager can use them and write to them. In my case it is going fine as long as I do not tick the second checkbox for Jetson image creation. If I select Download only it goes through and will dowload to a) available 15Gb at root partition, b) to mounted sdcard, c) to inserted usb-stick;
But as long as I select the Install checkbox it will pop up message about space.
It is not at the flashing stage, it is in the very early stage of sdkmanager interface, thus it pertains to the Host procedure, not to the device flashing.
However, I shall try again.

couple of images

Hi Andrey,
Thanks for your clarification.
Perhaps you could try with command line install and see if it works. However, when flashing, it will take extra disk space at a mount stage. After flashing, it will free up the extra mounted disk space. I’m not sure if the current disk space is enough or not.

The command line install syntax looks like the following:
sdkmanager --cli install --user <user@email.address> --logintype devzone --product Jetson --version DP_4.4 --targetos Linux --target <board_P-Number> --flash all --targetimagefolder </sdcard/install/path> --downloadfolder </sdcard/download/path>
You could get a complete list of supported <board_P-number> in JetPack 4.4 then select the one that you have.
sdkmanager --user <user@email.address> --query

Thank you for sharing!
perhaps I can have 32+16+15 =63gb free total using all available space mounted to the filesystem. E.g. as tmp/ usr/ /home & tmp folders.
I will give it a try.

945-82972-0005-000* is what written on the boardf
which of the following outputs of the query to use as device board P number? the first one??
P2888
P2888-0001
P2888-0004
P2888-0006
P288-0060
However, it will start awesome text interface thatt will throw the same disc space issue even if I select very few post install components

  • mounted Google cloud Platform [GCP] instance folder via sshfs to the Host

sshfs -o “IdentityFile=/keyfile” sserviceaccount@ipaddress53:/home/username/sshfs/ sshfs/
The authenticity of host ‘ipaddress’ can’t be established.
ECDSA key fingerprint is SHA25randomvalues.
Are you sure you want to continue connecting (yes/no)? yes
Enter passphrase for key ‘/keyfile’:

  • selected the sshfs folder as target for download and image install
it has got through the space issue, as it seems to me

it has got through the space issue, as it seems to me

Thank you for your update, Andrey. Glad to hear your problem solved.

yes, thank you for your assistance;
It wouldn’t be able to retrieve a file due to timeout;
But now I can get downloaded all files to local sdcard; then rsync them to sshfs folder, then construct Flash Image at the sshfs folder and try flashing so that that my Jetson will be flashed from Google Cloud Platform via sdkmanager installed locally though

│nux_R32.4.2_aarch64.tbz2 to /home/nvidia/sshfs/Jetson_Linux_R32.4.2_aarch64.tbz2                                                            │
│info: start to download https://developer.nvidia.com/embedded/secure/tools/files/jetpack-sdks/jetpack-4.4-dp/JETPACK_44_b144/T194/Tegra_Lin │
│ux_Sample-Root-Filesystem_R32.4.2_aarch64.tbz2 to /home/nvidia/sshfs/Tegra_Linux_Sample-Root-Filesystem_R32.4.2_aarch64.tbz2                │
│warn: retry to connect https://developer.nvidia.com/embedded/secure/tools/files/jetpack-sdks/jetpack-4.4-dp/JETPACK_44_b144/T194/Jetson_Lin │
│ux_R32.4.2_aarch64.tbz2 caused by Error: Download request timed out after 60 seconds. Closing connections                                   │
│warn: retry to connect https://developer.nvidia.com/embedded/secure/tools/files/jetpack-sdks/jetpack-4.4-dp/JETPACK_44_b144/T194/Tegra_Linu │
│x_Sample-Root-Filesystem_R32.4.2_aarch64.tbz2 caused by Error: Download request timed out after 60 seconds. Closing connections

final step will be

sdkmanager --cli install --user emailaddress --logintype devzone --product Jetson --version DP_4.4 --targetos Linux --target P2888 --flash all --targetimagefolder /home/nvidia/sshfs --downloadfolder /home/nvidia/Videos/

where directory Videos stands for sdcard & sshfs stands for remote GCP linux instance folder

Perhaps sshfs either does not support the full user/group/other IDs of ext4, or perhaps there is a security setting in configuration of sshfs which prevents UID 0 (I have not tested sshfs, but almost every remote filesystem type has security restrictions).

I managed to shrunk windows partition for 50 gb.
I used it for flashing and got black screen after flashing.
maybe 4.4 Jetpack doesn’t support by default usb-c monitors and awaits hdmi which I do not have?
it seems that I shall try console connection and troubleshooting

sudo apt install minicom
 sudo minicom -D /dev/ttyUSB3 -8 -b 115200

how to get to the oem config without display? how to connect interactively/ login via minicom?
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fflashing.html%23wwpID0E0WB0HA
It seems that the debug port [micro usb ] is merely read only
Moreover, it seems that interactive port is accessible from Host PC through /dev/ttyACM0
it seems that the minicom has issues with UTF8 and won’t display the oem interface correctly
with oem-configuration it worked for the initial setup and works with usb-c
resolved by
sudo minicom /dev/ttyACM0
with usb-c cable [ not theusb micro as in case with the debugging port]
it entered to the oem-configuratoin initial setup and after finishing it allowed to use usb-c. previously it was possible to use usb-c for the initial setup ubuntu