Install Jetpack on 16GB eMMC module

Hi
I can not install OS and Jetpack 4.4DP on Xavier NX module. I’m using CTI Photon Carrier board.
I used SDK manager and this command:

sudo apt update
apt depends nvidia-jetpack | awk ‘{print $2}’ | xargs -I {} sudo apt install -y {}

It always says

E: You don’t have enough free space in /var/cache/apt/archives/.**

I tried move downloaded pkg to Micro SD card and nothing change.

How could I install Jetpack in 16GB eMMC module?

Thanks!

what is the output of executing of the command below at the HOST PC?
df -h
Typically Host PC needs to have at least 40-50gb of free space in order to execute Jetpack flashing.

consider using this m if it matches your board https://connecttech.com/ftp/Drivers/CTI-L4T-XAVIER-NX-32.4.3-V003.tgz

Besides the disk space problem… actually apt-update may not work on ConnectTech board.

There are other forum topics related to it.

Let’s make it easier to understand… every custom carrier board from vendor have their own configuration. Thus, they are not installing pure jetpack on their board. It means using official nvidia update method cannot really make your board work.

Hi WayneWWW
I tried XavierNX 16GB module with Xavier NX kit. There are 1.8GB free space after install Jetpack4.4

xavier-nx@xaviernx-desktop:~ df -h Filesystem Size Used Avail Use% Mounted on /dev/mmcblk0p1 14G 12G 1,8G 87% / none 3,5G 0 3,5G 0% /dev tmpfs 3,8G 4,0K 3,8G 1% /dev/shm tmpfs 3,8G 38M 3,8G 1% /run tmpfs 5,0M 4,0K 5,0M 1% /run/lock tmpfs 3,8G 0 3,8G 0% /sys/fs/cgroup tmpfs 777M 120K 777M 1% /run/user/1000 xavier-nx@xaviernx-desktop:~

I dont know why CTI carrier board with a little HW modify can effect the Jetpack.
I’m using rootfs on SD card instead.

Actually, it is just board name problem. If you put the CTI kernel/dtb to the jetson board config, then this problem shall be disappeared.