I can't flash the Xavier board from jetpack 5.0.1 version image to jetpack 4.6 version image

Hi Team of experts

I flashed my xavier board to Jetpack 5.0.1 verison with SDK Manager. But it always fail when want to reflash the board to Jetpack 4.6 version.

I have tried both SDK manager and flash.sh script.

When I use SDK manager, the usb device will disconnect and reconnect in one seconds, and then it report the error log 17:10:53 ERROR: Flash Jetson Xavier NX - flash: Error: Target board not found.

And I also get fail log by using flash.sh script like below:
'Error: Return value 2
Command tegrarcm_v2 --download bct_bootrom br_bct_BR.bct --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt --download bct_mem mem_rcm_sigheader.bct.encrypt
Failed flashing t186ref.

flash_xavier_fail.txt (41.7 KB)

Is your jetson NX a 16GB one? If you are not sure, check if you can flash it with rel-32.7.2.

My board is Jetson Xavier NX 8GB.
I tried to use a brand new board or a board with jetpack 4.6 image in it, and it worked fine. Only the board that flashed jetpack 5.0.1 image will fail.

Where are you booting from? Do you only have EMMC or is there some M.2 NVMe SSD involved? If the latter, I had to boot from the M.2, then flash the EMMC to the version I wanted, boot that, and then re-flash the M.2

I only use emmc flash now.

The error from your picture does not match the log you posted.

The log shows invalid value of DRAM parameters. That is why I suggested to try latest release. In case this is due PCN update.

[ 7.4618 ] 0000000000000102: E> NONE: Invalid value MemBct dram size: 0MB for slot: 2.

Hi Wayne

This board can be flashed successfully with the latest jetpack version 4.6.2. But it still doesn’t flash to Jetpack version 4.6.

We did custom file system and kernel configuration in the Jetpack 4.6 SDK. Porting these changes to 4.6.2 will take some efforts.
So I wonder if there is any way to flash this board to Jetpack version 4.6? Thanks!

Hi,

Please check if you need to apply those PCN patches in this page. I really wonder if your module is a 8GB one… since we don’t really have any special patch added for 8GB case between 32.6 and 32.7 which would affect “flash”.

Sorry, I just confirmed that this board is 16G Dram