Flash JP5.0 DP to Xavier NX 16GB failed

Hi Nvidia,
We tried to flash Jetpack5.0 DP to Xavier NX 16GB.
We use NX DevKit carrier board with NX 16GB SOM(PN:900-83668-0030-000).

And we selected “Manual Setup - Jetson Xavier NX” in SDKManager, but error occured as following message.

image
SDKManager error message:
image
Then we used command line mode to flash to module, you can see the error message is “Failed to verify image bct_mem”.

Should we add any patched files for the 16GB NX?

Is this a NVIDIA developer kit or your own custom carrier board?

Hi Wayne,
We use the carrier board of NX developer kit, and put NX 16GB SOM on it.

Could you also validate if jp4.6.1 is able to flash it?

Yes, We can flash JP4.6.1 to the same NX 16GB SOM.

Please share the full flash log as a text file. I mean error case of jp5.0 DP.

Hi Wayne,
Please check the attached files.
nx16GB_flash.txt (42.4 KB)
nx16GB_sdkmanager.txt (6.1 KB)

Hi,

Please also apply this PCN patch from rel-32.x to your rel-34. Seems not included in rel-34.

Jetson Linux R32.6.1 Release Page | NVIDIA Developer → XNX-16GB-r32.6.1-overlay.tbz2

@WayneWWW I have the same exact issue, applied the patch and now "“Failed to verify image bct_mem” issue is solved but the flashing hangs on: [ 8.1996 ] tegrarcm_v2 --isapplet

Our carrier board is Seeed studio’s A206 board.

Please describe how you apply the patches.

Hi Wayne,
We applied the patch to JP5.0DP, but we got the same problem as omers problem. Attached is the log for your reference.
JP5.0DP_flash.txt (51.8 KB)

We replaced the files from xnx-16gb-r32.6.1-overlay.tbz2 to /Linux_for_Tegra/bootloader/t186reftegra194-a02-bmpm-p3668-a00.dtb& /Linux_for_Tegra/bootloader/t186ref/BCT/tegra194-mb1-bct-memcfg-p3668-0001-a00.cfg.

Could you dump the uart log when the board is running flash and share it?

Hi Wayne,
Please find the attachment.
console_log.txt (5.7 KB)

HI,

Are you sure this is the full log? I mean ddi you see any log prior to that “Welcome to MB2”?

Hi Wayne,
No, We use minicom and putty to collect the log, all the log prior to the “Welcome to MB2” is garbled symbol.

Attached is the uart log from process of flash JP4.6 to the same 16GB SOM. You can see the flash is done, the readable message is also from “Welcome to MB2”.
JP4.6_flash.txt (84.5 KB)

We have JetPack 5.0.1 DP release, that issue was fixed in this new version.
Please get it a try: Announcing JetPack 5.0.1 Developer Preview with Jetson Linux 34.1.1 - Jetson & Embedded Systems / Jetson Xavier NX - NVIDIA Developer Forums

Thanks