XavierNX 16GB Not Working

Following are the observations after testing the carrier board with XavierNX

  1.   The board did not boot with the SOM(Xavier NX) that came along with it.

I tried flashing the board using the SDK manager but it kept failing.

  1.   Replaced the default SOM on the Carrier board with another Xavier NX SOM,

This time the board did boot and was working perfectly fine.

  1. Tried flashing the non-working SOM using another carrier board, yet the flashing process kept failing.

So here the carrier board is all from Xavier NX devkit?
Is NX module a SD card version or eMMC version?
Any log can be as reference?

And which jetpack version is in use… if you are not using some new jetpack release, then by default it won’t work.

Carrier board is from NVIDIA Partner Aetina. NX is eMMC Version. Flashing is getting stuck when we try to flash via SDK manager.

Jetpack version used is Jetpack 4.6.1. Also tried with Jetpack4.6

As kayccc’s comment,. do you have any log from sdkmanager to share?

You can click the export logs button on the GUI to dump log.

AN810_AutoNext_log.txt (2.2 KB)
Error_logs_AN810.txt (7.7 KB)
Error_logs_AN810.txt (7.7 KB)

Are you sure you know how to flash jetson boards? Do you have experience in flashing other jetson NX devices?

The log says you are not putting the board into recovery mode.

14:17:46 ERROR: Can not find matching device in recovery mode.

Also, your host machines does not have network connection?

Hello @WayneWWW,

We tried flashing the same SOM on a different carrier board, that we had earlier used for flashing and it was successful but this specific SOM kept failing during flashing.
Can you suggest any other method.



There is no special trick if your error is just “cannot find board in recovery mode”. Cannot enter recovery mode is pure hardware issue.

Please try more cross validation with different modules/carrier board and host machine to see if this is only specific to the module.

If that is an issue from module, then you can only RMA it.

If you don’t know what I mean here, please also tell.

I have tried flashing using other carrier boards but the issue still persists.
I have followed the same steps as mentioned in the SDK manager.
Will try out once again, meanwhile I have shared new logs, please check.

sdkm-2022-07-13-10-44-55.log (466.7 KB)



Are you using jp4.5.1 to flash NX 16GB? 4.5.1 does not support NX 16GB module…

@hitesh.pant21 , are you coworking with @anand.rude ? I just want to make sure we are all talking about same error on same devices. But not something different.

Yes we are working on the same issue and talking about the same error.

Can you people just share the log with correct jetpack version?

Following are the logs when I tried to flash jetpack 4.6 on the SOM:

sdkm-2022-07-13-17-24-16.log (309.4 KB)

I followed the flashing steps as mentioned on the SDK manager, but still failing

Jetpack4.6 by default does not support NX 16GB either… Could you just use jetpack4.6.1? Just select the latest version in your sdkmanager to flash…

Hello @WayneWWW,

We have tried flashing with Jetpack: v4.4, 4.5.x, 4.6, 4.6.1, but it fails every time.
after 33.33% it doesn’t complete the flashing and fails.

Please help to approve the SOM module for RMA.

Thanks and Regards


Can you just flash it with jp4.6.1 and share me the log but not just keep telling me “it failed, that failed”.

Seriously, I cannot approve anything just from your unclear description. We need logs. Not just these comments.

I don’t know what goes wrong here. I already said many times, only version >= jp4.6.1 can flash NX 16GB by default. You don’t need to try any previous version and tell me it cannot work. That was expected.

Please share me both host side log and uart log during flash error happens.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.