Error flashing Xavier NX 16GB on SD Card on Auvidea Carrier Board


I have a JNX30D, SKU:70879, SNU: 03620384 carrier board and Xavier NX 16GB module board connected to it. I am using the firmware provided on the website and 64GB microSD card to first flash. I followed the guide but I keep getting the same error. I shared the screenshot. Please help,

I tried running “sudo bash flashcmd.txt” using different USB cables and on different computers, nothing changed.

The website says it supports the modules with 8GB Ram, I could not found any distro which claims the support for 16GB module. Is there any or could it cause the problem?

Thanks in advance!

Hi, is not able to flash data to any external drive.

If you sdcard slot is on the carrier board but not module, then it is an external drive. I remember that NX 16GB only has emmc version, which means your sdcard slot is probably added by vendor.

Hello again, thanks for your answer.
Yes the sdcard slot is not on the module and NX has 16GB emmc. I tried the flashing command after I plugged off the sdcard and I get same error. So it is not able to flash on emmc too. Is there anyone faces with the same issue?

I am wondering that is the flashing script looking for an ssd as default and when it can not find process finishes with an error. I couldn’t find some command or option to change it or something.

Any idea will be appreciated.


Actually, you should share whole log and how you flash the board first… I don’t see anything helpful from just that screenshot.

Also, why are you using flashcmd.txt to flash? Who taught to use that? Is this your first time ever flashing a jetson device?

Hi thanks for your interest. No actually I used Nano and AGX Xavier Dev Kits and flashed them many times. But it is first time I use a carrier board produced by some other company. I use flashcmd.txt according to guidance provided on the producer’s website.

I am uploading two adjacent terminal logs and the guide document I followed. It provided on the website of carrier board producer which is Auvidea.

First log:
flashlog.txt (19.9 KB)
Second log:
flashlog1.txt (19.7 KB)

And the guide I followed:
QuickStart-1.pdf (663.5 KB)


So they just provide you a “bootloader” directory but not the whole “Linux_for_Tegra” folder?

Do you know what is the jetpack release they are based on?

There is only one supported release and it is 4.6. The answer for first question is yes only bootlader folder I have.
I am also wondering that is there any chance that JetPack 4.6 is not supporting Xavier NX 16GB?

Actually, I know there is a patch needed if anyone wants to use 16GB NX with jetpack4.6.

If you are using jp4.6.1 or 4.6.2, then that patch is not needed. However, you don’t have Linux_for_Tegra folder and also not able to upgrade the BSP version.

I would suggest you contact the vendor for this issue.

Thanks for your time, I did contact but no response so far. I kindly ask you to keep this topic open in case of someone who faced or solved the same issue would make an update.

Hello again, my issue is solved thanks to guidance of one of the engineers at OpenZeka, an Nvidia Partner company in Turkey, @scalpaslan. Here are the steps I followed.

  1. In NVIDIA SDK Manager, select Xavier NX module as Target Device and JetPack version 4.6(rev3).
  2. Just select Jetson OS and start downloading. Press the skip button on the windows that appear. Close the app after the download is finished.
  3. Download the folder in this link and extract it to a folder.
  4. Go to the download address of Jetson OS (go to Linux_for_Tegra folder). Paste the contents of the folder you downloaded and extracted in step 3 to the corresponding places in the Linux_for_Tegra folder. Do not copy the folder directly, just copy the contents of the folder.
  5. Download the Xavier NX BSP file by clicking the link here, extract it to any folder and copy its contents to the Linux_for_Tegra folder I mentioned in step 4.
  6. After the copy process is finished, in the Linux_for_Tegra directory,
    sudo ./
    run the command.
  7. Connect the Ready Artificial Intelligence Kit to the computer with a micro usb cable and put it in recovery mode.
  8. In the Linux_for_Tegra directory
    sudo ./ jetson-xavier-nx-devkit-emmc mmcblk0p1
    run the command.
  9. After this step, you can follow the steps in the document for JetPack SDK Components.

I am having the same issue now. Could you post the solution with the links working? Thanks


Link in the 3rd step:

Link in the 5th step:

Thanks, I got it working 👍🏼

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.