Not enough disk space - Ubuntu 18.04

I’m trying to flash my Jetson TX2 with jetpack 4.4 using SDK manager.

It reports needing 23 GB and I have 40GB available:

francio@Deathbook:~/Downloads$ df | grep home
/dev/nvme0n1p6 80530928 36098592 40298500 48% /home

Still tells me that I don’t have enough disk space.
Tried setting the Download folder on another partition, but get the same issue.

Thanks in advance and let me know any other information which might help.


Do you have 23GB free on / ?

My suspicion is that’s what it checks.

Solution? You can either redo your partition layout, or download the BSP tarball, and other packages manually. You’ll have to use from the command line but it might be worth it to avoid SDK Manager.

1 Like

Yes, thats just what it is. I’ll see if I can rearrange stuff.
It just seems on the forum that the sdk manager doesn’t work well or is not clear enough for most people.

Thanks for the prompt reply and I’ll come back soon with more issues :P

Hi bertona89,

It takes about extra temporary 30 GB disk spaces during flashing, so 40 GB is still not enough. The displayed 23 GB is only for permanent disk space requirement. We’ll improve SDK Manager in next release to show this number clearer.