How to boot Jetson Nano in text mode?

Without serial console.

I’ve try insert text in /boot/extlinux/extlinux.conf

any ideas ?

thank you

To disable GUI on boot, run:

sudo systemctl set-default multi-user.target

To enable GUI again issue the command:

sudo systemctl set-default graphical.target

to start Gui session on a system without a current GUI just execute:

sudo systemctl start gdm3.service

The same instructions that work for any Ubuntu 18.04 system

4 Likes

thanks Caleb !!

Now there are more RAM available:

boot from text mode

$ free -m
Mem total 3956 used 319


Start X system from text mode:

$ sudo systemctl start gdm3.service

$ free -m

Mem total 3956 used 838

(with xfce instead of gnome desktop environment)

Hey Caleb,

I want to start the jetson nano in console mode (no serial) but with autologin enabled, what file do I need to write to, to enable it? and what text is inserted? thanks…

regards

There is no “autologin” without a session manager, and the session manager is a graphical system.

What do you really want to do? Start some software on boot?
The best way to do this is to create a “unit” file for your software in /etc/systemd/system/yourname.service
The documentation for these unit files can be found here:
https://www.freedesktop.org/software/systemd/man/systemd.service.html

Typically, if you don’t want the GUI, you’ll set-default multi-user.target, and then your service should require/start-after multi-user.target. Then you enable it with “systemctl enable yourname.service” and it will start on boot.

snarky, that’s what I want to! start some software on boot. I’m going to do that, Thanks a lot…

An important note, my Jetson nano would only display the console in text mode on HDMI. Scared me for a sec because DP was only a black screen.

This is working for me:

https://askubuntu.com/questions/819117/how-can-i-get-autologin-at-startup-working-on-ubuntu-server-16-04-1/819154#819154

1 Like

Hi, would it be possible to show the text console on the dp port?
Or, hide te tekst console in any sort of way?
Thanks

gdm3 connects to the network even without logging in at the login screen.

Same is not the case when GUI is disabled.

Jetson in non-GUI mode does not connect to the network on the black login prompt screen.

Probably you’re looking for auto connect to the network at the login prompt. So that ssh finds the device.

Look at the solution below… That worked for me. :)

connect to network for all users at login screen

Hi,
Thanks for the reply.
Actually, I don’t want the network login. I use the nano as a video player.
Therefore I want the screen be completely black, without the tty1 login:
For now I solved it by changing from gnome to lxde desktop.
Auto-login and hide the bar and set the desktop to black.

A more neat way would be to disable the graphical.target and hide tty1.
(it will also save some memory, all though there is not really a lack of it with one 4k video file and 4gb :)

Hi guys,
you may use the tool jetson_config → desktop → [B2] console auto-login. this works fine for me.

1 Like

Hi.
I disabled the GUI and set up automatic login, but I am prompted to enter the password at the console.
User input is automatic.

Automatic login settings:
/etc/systemd/system/getty.target.wants/getty@tty1.service
ExecStart=-/sbin/agetty -o ‘-p – \u’ --noclear %I $TERM --autologin “username”

I want to log in automatically with GUI disabled when I start it. What other settings should I make?