How to connect to the develop board after flashing with ssh?

Dear sir: I am developing at jetson nano, i have not hdmi cable. After i flashing the system(sudo ./flash.sh jetson-nano-devkit-emmc mmcblk0p1) , I connect to board with command ssh@ubuntu 192.168.55.1 , but is show the connection is refused. I can ping 192.168.55.1 , how can i do next?

You may not pass the first steps:
EULA, Locale, language, KBD/mouse and create user account etc.

TODO, HDMI monitor and KBD/mouse should be attached to your Nano.
[modified]
You can setup your Nano with headless mode too!
Refer ‘initial setup headless mode’ at the below:

Technically this command is wrong:

What login name did you create from the step mentioned by @MtHiker? This is key. Let’s say the name is “myself”. In that case:
ssh myself@192.168.55.1

You need the step from @MtHiker before you can have a login name (that is the step which creates the account name). If you have that done, and it refuses connection, then there is a network problem (e.g., firewall). Note that a refused connection is quite different from many other login problems, so be very specific with the failure message if you still have an error.

Dear sir:

I didn’t create the login name as mentioned by @MtHiker. Cannot init these setting( EULA, Locale, language, KBD/mouse and create user account etc.)in the rootfs without hdmi?

You can use l4t_create_default_user.sh script on the host before you flash the board.

Refer to the " Skipping oem-config" section.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html

Dear sir:
Tks!

when do i run the l4t_create_default_user.sh script?

Is at the time when the nano is in recovery mode and it is connected to host pc?

As I already said “before you flash the board.” Is there any problem to understand that?

FYI, the l4t_create_default_user.sh script modifies the “Linux_for_Tegra/rootfs/” content, which is what then gets used to create the flash image. This only needs to be done once.

1 Like

Tks!

It can auto login, but if i input “sudo xxx” , it reported the error:
ubuntu@tegra-ubuntu:/dev$ sudo cat ttyUSB0
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set

Can you help me?

Sounds like your host PC did not have a Linux native filesystem. Perhaps you used a VM? Sometimes people have a disk running on NTFS filesystem type, or even VFAT. These filesystem types have no understanding of Linux filesystem security, and are incapable of preserving the setuid concept. If you are not using an ext4 filesystem, then you’ll have to reflash and make sure your host PC Linux install uses ext4 filesystem. To find out (on both Jetson and host PC):
df -H -T /
(if it shows ext4 it is good to go, but if showing something lime ntfs, then flashing again will be required)

Note that I only showed the root filesystem type in that above command. If you had a different hard disk mounted on your host PC’s home directory, then this would be what requires type ext4.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.