How to enable DSI on TX1?

Is there a way to enable DSI in the state where there is no DSI module in JetsonTX1?

I tried the following method, but an error occurred in DC at startup.

Copy “kernel/arch/arm/boot/dts/panel-s-wuxga-8-0.dtsi” to “kernel/arch/arm64/boot/dts/”.

[ 2.119248] tegradc tegradc.1: DT parsed successfully
[ 2.124422] dc_hdmi_hotplug_init: no valid hdmi node
[ 2.149882] tegradc tegradc.1: Error: out->type:1 out_ops->init() failed
[ 2.156491] tegradc tegradc.1: failed to initialize DC out ops
[ 2.162362] tegradc: probe of tegradc.1 failed with error -22
[ 2.168502] tegra_camera_platform tegra-camera-platform.45: tegra_camera_probe:camera_platform_driver probe

I have another question with addition.
Does DSI support 4 lanes in the BSP of JetsonTX 1?

Hi kmatsuda,

Please refer to the dtb file p2371-2180.coonf mentioned. You don’t need to copy the device tree from one folder to another.

As for 4 lanes DSI, the answer is yes. Please refer to the TX1 TRM section 25.1.1.

Hi WayneWWW,

Answer Thank you.

I looked at p2371-2180.conf, but I did not understand how to activate and activate DSI.
Could you tell me the specific procedure as to whether you can start up with DSI enabled?

Hi kmatsuda,

In p2371-2180, this would indicate the dtb file you are loading. The source of this file is in kernel/arch/arm64/

The dtb file in p2371-2180.conf has a DSI panel configuration. I think few steps are required.

  1. Refer to the dts file I pointed out
  2. Modify the board-selection logic in board-panel.c
  3. Check the driver is running or not in dc probe.
  4. If the above are correct, panel should run.

Hi WayneWWW,

I was able to activate DSI successfully.

It is the reason why DSI was invalidated, but in BSP of TX1, we write to eMMC using jetson-tx1.conf.
However, the link of jetson-tx1.conf was not p2371-2180.conf, but it was p2371-2180-devkit.conf.
As a result, DSI was disabled in DTS.

Hi kmatsuda,
I have a similar issue as yours. Could please tell me how you activte DSI?