How to enable stereo mode on Kubuntu 16.04 LTS for Quadro K4200 graphic card?

Dear all,

I freshly installed Kubuntu 16.04 LTS on my computer and need help to enable stereo mode.

Indeed, on my old system I was able to set xorg.conf file as follow:

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 361.42 (buildmeister@swio-display-x64-rhel04-13) Tue Mar 22 18:37:28 PDT 2016

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”

Section “Files”

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"


Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"


Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “10”
SubSection “Display”
Viewport 0 0
Depth 24

Section “Extensions”
Option “Composite” “Disable”

and everything work well when I use quad-buffering.

But now, on Kubuntu 16.04 the xorg.conf file (normally in /etc/X11 folder) disappeared…
When, I built a new xorg.conf file and I put similar lines as above, I got a black screen when I launched Kubuntu…
I found that the line “Composite” “Disable” is the problem but removing this line I’m not able to see any 3D visualization.

Any idea?

Thanks in advance.



NB: version of driver installed 378.13

In short: wrong distro.
3D Vision and compositing are mutual exclusives so you need a non compositing window manager / desktop environment like mate or xfce with compositing disabled. Kubuntu uses kde/plasma which depends on composition.

Hi Generis,

Thanks for your reply. I was getting crazy!! So I will download Xubuntu 16.04 and I will let you know if I succeed or not.

Best regards,


Hi Generix,

I installed this morning Xubuntu 16.04 LTS and the nvidia driver version 378.13 using ppa repository (because the driver from nvidia 375.39 didn’t work).

I configurated the xorg.conf file as in my old configuration and I reboot my computer.

So now, I’m able to see the stereo running (command glxgears -stereo for checking)! Thanks a lot for your help!!

Now, I have another question regarding the stereo effect, it seems that the stereo effect is running “inside” the screen and not “outside”. Indeed, with my old configuration, when I ran stereo, I was able “to touch” with my hand object going outside the screen.

Maybe you know, how I can set the configuration file to see this effect again.

Thanks in advance,

Best regards,


Check if left/right eyes are swapped, i.e. put on your glasses bottom up.

Dear Generix,

Thanks for your reply. I checked what you said but it is still the same…