NVIDIA Quadro cards working with 3D

we have a Linux machine RHEL 7.6 that I just installed + NVIDIA Quadro P4000 with latest NVIDIA driver 510.73
and that is what I configured in Xorg file:
Section “Extensions”
Option “Stereo” “10”
Option “AllowDFPStereo” “yes”
Option “UBB” “True”
Option “Composite” “Disable”
Option “AllowGLXWithComposite” “true”

yet its not working

Which DE are you using? What doesn’t work exactly?
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thanks for your response.

what do you mean by DE ?

what doesnt work exactly ? We get an error when trying to launch glxgear, just to check that the 3D capabilities are set up correctly. Something with missing RGB…
So far we couldn’t find how to solve it.

How can I share /add the bug report to post ?

DE=Desktop Environment, i.e Gnome, XFCE, KDE…
Please use the upload button, horizontal line with upward arrow in the line of formatting options when writing a post.

Desktop Environment is GNOME

nvidia-bug-report.log.gz (289.6 KB)

There are several problems:

  1. you can’t use Gnome3 as DE since it needs composition to work while this has to be disabled for stereo to work. Please switch to xfce or kde or something else.
  2. you’re running an RHEL version with a bug, extension names are case sensitive, so COMPOSITE instead of Composite has to be used.
  3. many options you set are outdated and in the wrong xorg section.

Please switch DE and then use this xorg.conf:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro P4000"
    Option         "Stereo" "10"

Section "Extensions"
    Option         "COMPOSITE" "Disable"

Thanks I will try that.
1st I need to check how to get KDE to work


When configured the suggested conf , now the display is blank / black.

Please advise

when configured suggested configuration , Linux displays shown blank/ black and only after disabled #Option “COMPOSITE” “Disable” , then displays issues solved.
still on GNOME desktop and trying to figure how to switch to KDE , anyhow , please advise also about the problem that this “Option” configuration in Xorg file causes.


I managed to switch to KDE , yet again , only after disabled that configuration line in Xorg file #Option “COMPOSITE” “Disable”.

I have installed “Mate Desktop” and #Option “COMPOSITE” “Disable” is working as you suggested , yet still same error message
#glxgears -stereo
Error: couldn’t get an RGB, Double-buffered, Stereo visual

Please create a new nvidia-bug-report.log.

nvidia-bug-report.log.gz (286.7 KB)

You still have a broken xorg.conf, please delete it and use tthe one I posted.