Quadro P4000 3D vision 2 not showing stereo

Hi,
I am having problem in setting up stereo on linux with Quadro P4000 card and 3D vision 2.
The monitor is Acer GN246HL (3D ready).
Nvidia driver 410.79.
Running centos 7.6 with 3.10.0-957.10.1.el7.x86_64 kernel.
The system has additional 3 GeForce RTX 2080 for CUDA.
Using UltraAV ACCELL adapter for DP to DVI-dual link (which supports 3D stereo) with usb for power supply.

The exact problem is when I go to stereo mode application (for example glxgears -stereo) the monitor goes between mono and stereo mode with in between black screen. Occasionaly complains about incorrect cable also.

Our application is for crystallography using programs like pymol and coot.

Any help or suggestions…

Thanks
Karthik

In addtion the dmesg gives a line:

nvidia-modeset: WARNING: GPU:0: Unable to perform 3D Vision handshake with Acer GN246HL (DP-4.2).

Thanks
Karthik

nvidia-bug-report.log.gz (1.14 MB)

Are you using any kind of active converter to connect the monitor to the graphics card?

Ok, stupid question, you wrote it. Does it work with a passive converter, at least at lower refresh rates?

Hi, thanks for the reply. In passive converter it is not even go to stereo mode, as it supports only 60Hz.

The manufacturer of the converter states that it supports 3D Vision
https://www.accellww.com/collections/adapters/products/ultraav-displayport-or-mini-displayport-to-dvi-d-dual-link-adapter-with-3d-support
but I suspect the failing handshake is due to the converter:
https://devtalk.nvidia.com/default/topic/950579/linux/unable-to-detect-ir-usb-emitter-on-ubuntu-16-04/post/4949547/#4949547
Did you contact Accell to clarify if you’re using the correct cables?

The DP to DVI-dual link adapter cable was recommended by Nvidia in the following site:

https://nvidia.custhelp.com/app/answers/detail/a_id/4449/~/nvidia-recommended-display-adapters

A slight difference between the question discussed in the following forum

https://devtalk.nvidia.com/default/topic/950579/linux/unable-to-detect-ir-usb-emitter-on-ubuntu-16-04/post/4949547/#4949547

In my case, I do get slight green dim light on the IR emitter. If I go to stereo mode, the IR emitter goes bright green too. However, the display toggles between mono and stereo continuously and it is not stable.

I did not contact the Accell till now. May be I will give a try.

Thanks
Karthik

I am just attaching a video about the problem.
IMG_1883.MOV (5.05 MB)

Anybody from Nvidia can help to sort out this problem?

You could mail the log to linux-bugs[at]nvidia.com for more attention.
You should rule out some things beforehand:

  • Does installing a more recent driver (e.g. 418.74 or 430.14) fix the issue
  • Does the setup work when using Windows (the linux driver sometimes has problems with active converters)

I tried with new both with 418 and 430 drivers. Both did not work. Not checked with windows. The system is preinstalled with some software. Will check with system supplier. Also I fill file bug report.

I have a new RHEL 7.6 system with a P4000 and Samsung SyncMaster 2233RZ that I’m trying to setup (also for crystallography software), but I’m not having any success even starting X. (But I’m not using an active adapter, so that’s probably my problem.) Any luck with nvidia support? Please follow up if you hear back from them.

BTW, don’t try anything newer than 418 - they don’t support 3D Vision anymore after that version. https://www.engadget.com/2019/03/11/nvidia-ends-3d-vision-support/

Ok. I mailed the problem to linu bugs. Hope the will get back to us. I will not able to check with windows currently.Sorry. If anything comes up I will let you know…

@skarthik14 I bought the Accell adapter and now I’m having the same issue you are - the screen switches between mono and stereo with a blank screen in between. Have you had any luck with nvidia support?

Nope. Not yet. I don’t know how much time they will take or will they even respond? Did you try to check the same in windows ?

It’s a Linux only workstation so I’m unable to test it with Windows, unfortunately.

I’ve tried some of the settings in “nvidia-xconfig” without luck.

I’ll try contacting nvidia support also.

Any luck with the installation? Still I am waiting for the reply from nvidia support…

Maybe PM that user:
https://devtalk.nvidia.com/default/topic/1055231/linux/problems-with-x-server-after-driver-version-430-14-is-installed/post/5349209/