Cannot get 3D Vision 2 to work...

We are trying to get Quadro FX3800s to work in 3D stereo on Linux with newer Asus or Acer 3D vision compatible screens. The screens DO NOT have the built-in emitter (wish you could still buy those). The newest driver for the Quadro FX series is 340.96, released in Nov 2015, and that is what we are using.

The symptom is that the emitter LED never turns green or syncs with the glasses . The kernel sees the emitter, the driver sees the emitter (Xorg.0.log reports it) but it never gets activated. We don’t see any error messages of any kind. I’m pretty sure we have the software configured OK, because if we swap in one of the original 3D vision (1) emitters, it turns green and stereo works beautifully on the Asus monitor.

Even with the older emitter we do still have trouble with the Acer screen, but it’s because the Acer screen doesn’t think stereo is available even though we are driving it at 1080p/120Hz. The front-bezel 3D settings screen is greyed out and you can’t navigate to it.

The old emitter does turn green and syncs up with the glasses with either screen.

Any ideas? We have had this technology working for years. Went to upgrade a bunch of boxes with 3D stereo and have had nothing but headaches. I feel like we may be missing some key bit of info.

Hi Jarrod,

You are not alone with this problem. It is not your setup either… I’ve had a case open with NVIDIA since July 19, 2016 about this issue and after it was elevated to their Level 2 support the status has been “Researching” since August 03, 2016.

We have several Linux computers that use the NVIDIA 3D Vision (Version 1) emitters without issue as well. And the computer we are trying to use the 3D Vision 2 emitter on uses a Quadro FX 3800 card with the 340.96 driver. And the emitter has a blinking red logo.

As near as I can tell the issue is the firmware is not uploaded to the emitter in Linux. This page was a great help for figuring out the problem, http://users.csc.calpoly.edu/~zwood/teaching/csc572/final11/rsomers/ .

I tested this on a different computer that has a dual boot setup with RHEL 6 and Windows 7. if I connect the emitter to the computer and boot into Windows it lights up green and if I reboot into Linux the emitter stays green while in Linux. When I turn the computer off then back on and boot into Linux the emitter exhibits the same behavior of the flashing red light.

I even exchanged the 3D Vision 2 emitter because I thought it was defective but unfortunately that was not the case.

I hope this helps!

Thanks for your reply. While it is good to know that we’re not alone, it’s not a good situation to find ourselves. We need to have 3D stereo but the technology appears to have regressed significantly in the last 1-2 years. For example, the inability to purchase screens with built-in emitters is a BIG step backwards. We used to be able to get stereo out of e.g. Quadro K620s without the hardware sync cable. Pretty important when you are outfitting a lab with 15-20 workstations…but I digress.

I had seen the bit about the firmware upload but figured that since it was working on the older emitter then it must not be necessary in Linux . I guess I don’t know enough about how the hardware inside the emitter works well enough to know what impact this might have. If you can PM me the info on how you were able to open a case with nVidia I will open one as well. It can’t hurt for more users to keep the pressure on. I’ve spoken to colleagues and ask what they have been doing and.the answer is a bit sad. They look on ebay for used/refurbished monitors that have the build-in emitter. I’m afraid this isn’t really a solution at all, at least not a sustainable one.

Thanks again for your reply.

Update: we got the newer Acer monitor to work on the older emitter by using the “acquire EDID” feature of nvidia-settings to save the EDID of the older Asus monitor (that is in the monitor EDID database of driver version 340.96), and then plugging the new monitor back in and passing that EDID to the driver via the “CustomEDID” option in xorg.conf.

nvidia-settings now happily reports the new Acer monitor as the older Asus model and stereo works fine.

So do the newer Linux drivers know how to upload the firmware to the new 3D Vision 2 emitters? Is the problem we are having simply due the fact that we are stuck with 340.96 on FX boards, and that driver revision doesn’t know that it needs to deal with the newer emitter firmware? Or does 3D Vision 2 not work with Linux at all?

Sorry for the delay.

I tried the 3D Vision 2 emitter on one of our Linux workstations that has an NVIDIA Quadro 4000 card installed and running driver 367.27 with the same symptoms as the older driver.

To open a case go here (You may need to login) and fill out the form https://nvidia.custhelp.com/app/ask

This is a known problem that’s tracked by internal bug 1800168.

Hi Aaron,

Thanks for the confirmation. Any word on when/if this bug will be addressed?

Chris,

Is there anyway you can confirm it is not a damaged/faulty stereo 3-pin adapter for the Quadro?

Zack

Thanks for the confirmation. Hopefully a fix is forthcoming. I’d rather use a nvidia solution end-to-end vs going 3rd party for emitter/glasses.

Hi Zack,

Yes I can confirm it is not a faulty 3-pin VESA stereo cable. While using the same cable I attached a 3D Vision 1 and after restarting the Linux computer, the emitter was working. Then after switching back to the new 3D Vision 2 emitter and restarting the computer the emitter was not working.

I wish it was a faulty cable.

Chris,

What monitor are you using?

Zack.

I’m not sure what monitor we are using has any impact on the 3D Vision 2 emitter not receiving the firmware.

But, we are using an ASUS VG278HE.

I put together a linux utility inspired by libnvstusb that loads a firmware onto the 3D vision 2 emitter. It (sort of) works. I used the libnvstusb firmware extraction tool to get emitter firmware out of the Windows nvstusb.sys driver. However, this appears to extract the firmware for the older emitter (USB Product ID 0x0007). When I flash it to the newer emitter (USB Product ID 0x7003), it changes the Product ID of the emitter to 0x0007. Linux USB doesn’t enjoy having the Product ID changed out from under itself and my utility segfaults. At that stage the emitter is green, but non-functional, and the Product ID of the new emitter matches that of the old emitter 0x0007. Since the product ID on the device is a match with the firmware I’ve got, a second flash works well enough to put the emitter in a state where the nvidia driver will load a double-buffered stereo display on our Acer DFP (spoofed as an older Asus EDID). But there is a weird eye inversion issue. Upon login, you always have to load nvidia-settings and toggle the Eye Inversion button, no matter what value it was set previously (or, if your application has eye inversion built-in, you always have to toggle it to the opposite of how you left it previously). But yeah, after jumping through these hoops we have beautiful DFP stereo on Linux using the V2 emitters.

FYI, When you unplug/replug the V2 emitter, it goes back to being recognized as Product ID 0x7003. None of the changes appear to be persistent across a power cycle.

What I’d like to do is figure out the firmware signature of the new emitter, so I can get the correct firmware extracted from the Windows driver. No idea how to do that though…maybe sniffing the USB interface in Windows upon plugging the emitter in?

Same problem here:
We have 10 brand-new graphics stations with new 3D Vision 2 emitters which are not recognized by the driver.
Hardware: DELL Precision T5810 with Nvidia Quadro M4000 under Debian, no double boot.
Any tricks to work around the problem efficiently are welcome!

Nvidia tells me that there will be a fix for this in the 367.xx series Linux driver, due out in a couple weeks or so. If your cards aren’t supported by this newer driver, you are stuck for now. I requested they add it to the 340.xx series and was told they are “looking into it.”

This is a major issue for us too… I used to configure Nvidia 3D Vision with the VESA bracket without any issues, and now with the new 3D Vision 2 kit, it just doesn’t work… I’ve tried using latest NVIDIA drivers, and older ones too… I tried using K4000, K4200, and M4000… without any success. It worked fine with QuadroFX and Nvidia 3D vision #1. How can Nvidia released new product (3D Vision 2) without making sure it’s at least compatible with some of their product? the 3D VIsion #2 explicitly mentions compatible under Linux platform… ???

any updates here? Anyone from NVIDIA reading this thread? This is a real show stopper… I just tried same hardware, same configuration and driver versions, with NVIDIA kit #1, and guess what? It works! There’s really an issue with the new NVIDIA 3D Vision 2 kit and the Linux drivers compatibility… Can’t believe it…

I had a similar problem, and just noticed that on 2016-10-10 they updated the long term driver to 367.57
I just installed that on Ubuntu 14.04 and the IR seems to work (at least it lights bright green and
glxgears -stereo looks correct. This is with the Quadro M4000 and the DIN plug cable.

I heard back from NVIDIA:

The latest 367.57 Linux driver which has the 3D Vision fix is available here: http://www.nvidia.com/download/driverResults.aspx/108586/en-us

Unfortunately I haven’t been able to install this new driver and test it yet.

Fixed in Linux driver 367.57 released on 10/10/16. Confirmed working here on Quadro 4000 + 3D vision 2. If your graphics cards require an older driver, you are still out of luck for now, unless you do some version of the firmware hack I posted further up, or do a windows dual-boot workaround.