Unable to detect IR USB Emitter on Ubuntu 16.04

Driver version : 367.27
Ubuntu 16.04
Card: Quadro M4000
3 Pin din connector in use.
Emitter continues to flash red, at no point does it go dim or bright green.

Xorg.0.log reports:
[ 303.017] () NVIDIA(0): Option “Stereo” “10”
[ 303.017] (
) NVIDIA(0): USB IR emitter stereo requested
[ 303.018] () NVIDIA(0): Enabling 2D acceleration
[ 303.656] (–) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:3:0:0
[ 303.656] (–) NVIDIA(0): DFP-0
[ 303.656] (–) NVIDIA(0): DFP-1
[ 303.656] (–) NVIDIA(0): DFP-2
[ 303.656] (–) NVIDIA(0): DFP-3
[ 303.656] (–) NVIDIA(0): DFP-4 (boot)
[ 303.656] (–) NVIDIA(0): DFP-5
[ 303.657] (–) NVIDIA(0): DFP-6
[ 303.657] (–) NVIDIA(0): DFP-7
[ 303.657] (–) NVIDIA(0): DFP-0: disconnected
[ 303.657] (–) NVIDIA(0): DFP-0: Internal DisplayPort
[ 303.657] (–) NVIDIA(0): DFP-0: 960.0 MHz maximum pixel clock
[ 303.657] (–) NVIDIA(0):
[ 303.657] (–) NVIDIA(0): DFP-1: disconnected
[ 303.657] (–) NVIDIA(0): DFP-1: Internal TMDS
[ 303.657] (–) NVIDIA(0): DFP-1: 330.0 MHz maximum pixel clock
[ 303.657] (–) NVIDIA(0):
[ 303.657] (–) NVIDIA(0): DFP-2: disconnected
[ 303.657] (–) NVIDIA(0): DFP-2: Internal DisplayPort
[ 303.657] (–) NVIDIA(0): DFP-2: 960.0 MHz maximum pixel clock
[ 303.657] (–) NVIDIA(0):
[ 303.657] (–) NVIDIA(0): DFP-3: disconnected
[ 303.657] (–) NVIDIA(0): DFP-3: Internal TMDS
[ 303.657] (–) NVIDIA(0): DFP-3: 330.0 MHz maximum pixel clock
[ 303.657] (–) NVIDIA(0):
[ 303.657] (–) NVIDIA(0): BenQ XL2720Z (DFP-4): connected
[ 303.657] (–) NVIDIA(0): BenQ XL2720Z (DFP-4): Internal DisplayPort
[ 303.657] (–) NVIDIA(0): BenQ XL2720Z (DFP-4): 960.0 MHz maximum pixel clock
[ 303.657] (–) NVIDIA(0): BenQ XL2720Z (DFP-4): supports NVIDIA 3D Vision stereo.
[ 303.657] (–) NVIDIA(0):
[ 303.658] (–) NVIDIA(0): DFP-5: disconnected
[ 303.658] (–) NVIDIA(0): DFP-5: Internal TMDS
[ 303.658] (–) NVIDIA(0): DFP-5: 330.0 MHz maximum pixel clock
[ 303.658] (–) NVIDIA(0):
[ 303.658] (–) NVIDIA(0): DFP-6: disconnected
[ 303.658] (–) NVIDIA(0): DFP-6: Internal DisplayPort
[ 303.658] (–) NVIDIA(0): DFP-6: 960.0 MHz maximum pixel clock
[ 303.658] (–) NVIDIA(0):
[ 303.658] (–) NVIDIA(0): DFP-7: disconnected
[ 303.658] (–) NVIDIA(0): DFP-7: Internal TMDS
[ 303.658] (–) NVIDIA(0): DFP-7: 330.0 MHz maximum pixel clock
[ 303.658] (–) NVIDIA(0):
[ 303.659] (II) NVIDIA(0): NVIDIA GPU Quadro M4000 (GM204GL-A) at PCI:3:0:0 (GPU-0)
[ 303.659] (–) NVIDIA(0): Memory: 8388608 kBytes
[ 303.659] (–) NVIDIA(0): VideoBIOS: 84.04.88.00.06
[ 303.659] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 303.659] (
) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 303.659] () NVIDIA(0): device BenQ XL2720Z (DFP-4) (Using EDID frequencies has
[ 303.659] (
) NVIDIA(0): been enabled on all display devices.)
[ 303.661] (==) NVIDIA(0):
[ 303.661] (==) NVIDIA(0): No modes were requested; the default mode “nvidia-auto-select”
[ 303.661] (==) NVIDIA(0): will be used as the requested mode.
[ 303.661] (==) NVIDIA(0):
[ 303.662] (II) NVIDIA(0): Validated MetaModes:
[ 303.662] (II) NVIDIA(0): “DFP-4:nvidia-auto-select”
[ 303.662] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 303.669] (–) NVIDIA(0): DPI set to (81, 80); computed from “UseEdidDpi” X config
[ 303.669] (–) NVIDIA(0): option
[ 303.669] (–) Depth 24 pixmap format is 32 bpp
[ 303.671] (II) NVIDIA: Using 12288.00 MB of virtual memory for indirect memory
[ 303.671] (II) NVIDIA: access.
[ 303.725] (II) NVIDIA(0): Setting mode “DFP-4:nvidia-auto-select”
[ 304.197] (WW) NVIDIA(0): No USB dongle device found.

dmesg reports:
[ 3.132440] usb 3-14: New USB device found, idVendor=0955, idProduct=7003
[ 3.132441] usb 3-14: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3.132442] usb 3-14: Product: NVIDIA stereo controller
[ 3.132442] usb 3-14: Manufacturer: Copyright © 2010 NVIDIA Corporation

Have tried setting the option “3DVisionUSBPath” “/sys/bus/usb/devices/3-14” with no luck.

Have disabled composite mode and installed xfwm4

Does anyone have any suggestions?

I have other Fedora 20 installs with K4000 cards working correctly with the same driver/config.

Thanks.

This looks the same as my issue:
https://devtalk.nvidia.com/default/topic/949594/linux/367-27-newer-n11071-ir-emitter-red-and-inop-older-n11071-green-and-working/

My older units work. Have you swapped one of the working units as a test.

Thanks for the reply.

Yes does look like the same issue, the emitters that are not working are the newer idProduct=7003

The others that do work have idProduct=0007

I’ve not able to swap them around to test as it requires a reboot of the workstations and they are in use.

Will try and arrange this over the next few days.

Yes, I switched to the older style emitter idProduct=0007 and I get a green light! So the new emitters do not work with the current driver. Unixbills; I understand from your other post that you opened a case with support, have they not been able to make any progress or accept that their current driver doesn’t support the new emitters?

Just looking on the box/packaging of the new emitter, it has no reference to Linux support and states you require a NVidia GeForce or Quadro GPU and Windows Vista/Windows 7…

It sounds like they have duplicated the issue and they said they would get back to us next week. Fingers crossed.

I just tested 367.35-1 with exact same results.

Had support suggested you try the new driver? I note there is no reference to 3D support or IR emitter in the release highlights.

No just as a test of current version. Support said they would get back to us this week.

Hi Unixbills, Did Nvidia support get back to you last week?

No not yet. All they said was they would have something for us on the “week of the 25th”. We are trying to follow up.

Hello,
I don’t know if this will fix your problem, but in my case it did.
I upgraded from Ubuntu 14.x to 16.04 with Unity then Gnome desk. I could not make the 3D worked (to make the story short).
Then, I reinstall the system with a USB installation of Ubuntu Gnome version without updates nor third part drivers.
The Linux system worked fine but without 3D (and red light on the emitter).
Then I installed the 367.35 driver, the problem still remained. I switched to xfce desk.
I had to use: sudo nvidia-xconfig --stereo=10, logout of the session and then I had the fade green light on the emitter. When I started a software with 3D display enabled, then got the bright green light and the 3D worked with the glasses.
Hope this will make your system works.

Hi everyone,

I have exactly the same problem. My configuation:

Ubuntu 16.04
Quadro M4000 video card
367.35 driver (the latest from nvidia website)
Monitor Asus VG278HE connected through Accell DP to DVI-D active adapter with 3D support
3 Pin din connector in use
stereo=10 and refresh rate 120Hz set

Emitter not working (flash red light): 942-11431-0007-001 P
Emitter working (green light): 942-11431-0007-001 G (just one letter difference!).

Unfortunately I didn’t write down the idProduct of the old emitter from the log file.

I have additional problem that the monitor doesn’t display in stereo (instead of flickering image, it is showing in mono), for example when running “glxgears -stereo”. I have this error message in the kern.log file that may be related:

Aug 12 13:15:49 TITAN-WK02 kernel: [ 35.237314] nvidia-modeset: WARNING: GPU:0: Unable to perform 3D Vision handshake with Ancor Communications Inc ASUS VG278HE (DP-6).

I have the active case with nvidia customer help, hopefully they can help me with this issue.

Support has asked us to send an emitter that doesn’t work. They say they can’t duplicate the issue. We still 100% success with the older units and 100% failure with the newer ones.

Thanks for the updates.

Our newer emitters also have the product no ending in P, while the working units end in J

Good news from NVidia support:

"
I reproduced the failure with your loaned unit.
I will report my results to Engineering and hopefully they will fix this problem soon.
Since we can now reproduce the problem, I opened a bug for Engineering to fix
I will keep you informed.
"

I am also seeing the same issue under Redhat Linux Enterprise 6.4

My unit actually has the number 942-11431-0007-001 R

Same problem on ubuntu 16.04 and a laptop with a K2100M, the xorg log says it couldn’t find the dongle.
My emitter sn is 0421916032447 and model 942-11431-0007-001 R

Any OS does the same.

We have been working with NVidia and they expect to have the driver out this month (October). We signed an NDA and trying to get the beta but probably wont happen.

I just installed the new 367.57 driver, the dongle is now detected, but the light is now light dim and the shutter glasses are not active. The same setup works fine in Windows 10.

I read that the 3-pin cable is required on Linux, so does that mean 3D is not supported on Linux laptops?

That’s correct. The sync cable is required.