Proplems with stereo unde k4200 in linux

Dear all,
I’m not shure wether this forum is the right location to adress my question. But I will try.Drop me a line if it’s not.
Here is a short description of my problem:
We are driving several workstations having an NVIDIA K4200 installed and connected with a NVIDIA Stereo emitter as well as NVIDIA glasses. The stereo emitter is connected with USB as well as with a sync cable connected to the 3 pin connector of the k4200. When a particular user is starting a 3D application under linux the green dark light of the emitter changes from dark green to bright green. An 3D works. For other users the 3D won’t work at all. Meaning it stays dark green. For some users this behaviour is just for special window managers. We have not idea what to change in wich configuration. Could any one give me an idea or advice?

Kind Regards,

Gregor Haberhauer

Dear all,

For those of you who are interested in a solution. Finaly I found the solution for KDE. There is
a setting in $HOME/.kde4/share/config/kwinrc wich is called OpenGLIsUnsafe. Setting this to true will result in a working 3D Stereo Emitter and glasses.
We are stille searching for a setting in gnome so if anyone has a advice you are welcome!



Please provide nvidia-bug-report by running script as root user.

Hello Gregor,

Until somewhat recently, the combination of composite + stereo has been unsupported in the NVIDIA GLX driver. Newer versions of the driver do support composite + stereo, but support for GLX stereo visuals is required in the composite manager as well.

The OpenGLIsUnsafe setting disables the kwin desktop effects in KDE. You should be able to use stereo in KDE by disabling desktop effects directly as well. GNOME 3.x does not support running without compsoite, as KDE does, but work to support stereo+composite in mutter (and by extension, GNOME 3.x) is in progress.

Here are bugs tracking support for stereo+composite in KDE and GNOME:

Until support is added in KDE, running KDE without desktop effects is a good workaround if you want stereo support. GNOME 3.x users will need to wait for an updated version with stereo support (GNOME 2.x should work fine with stereo), or will need to temporarily switch to a desktop environment with a non-compositing window manager.