Stereo mode not working on Linux + Nvidia Quadro K5000 setup


It’s been some weeks now for me trying to get the stereo working in a CAVE we have that is running on Ubuntu. The following items describe my setup:

  • OS: Ubuntu 17.04
  • Graphic Card: Nvida Quadro K5000
  • Graphic Driver: Nvidia Binary Driver - Version 384.111, nvidia-384 (private, tested)
  • Displays: Two BARCO Projectors (using the active glasses Barco Volfoni Edge 1.1)

About the X Server configuration, the important things to mention are:

  • The stereo is enabled, and configured with option 3, which corresponds to ``` Stereo Mode: Onboard DIN ``` , and that was chosen based on this documentation and some previous support provided by Nvidia Support Team.
  • The two Barco projectors are configured as a single screen:
    Screen Number: 0
    Dimensions: 3840x1200
    Refresh rate: 120 Hz

Once this was configured, I ran the following command in order to test the stereo feature:

glxgears -stereo -fullscreen

But the test application DOES NOT appear blurry (as in stereo mode). So, I’d like to get some help from you to see if there’s any configuration I might be missing. Please notice that I attach some additional config files:

Additional files:

Thank you very much in advance!