How to flash Jetson TX2 without device OS?

Once I installed JetPack on my Jetson TX2 correctly.

After few months later, I need external storage for TX2, because it had only 28 GB available.
I bought SATA flash drive and tried to mount.

But accidently I corrupted bootloader of TX2, mounting SATA Flash SSD to TX2.
So, now I want to flash my Jetson TX2 without device OS.

I installed python to host and tried many times, but couldn’t install JetPack OS (also devkits)

What can I do for it now?

JetPack (and its newer “SDK Manager”) install to the host PC running Ubuntu. The newest SDK Manager does require Python 2, and so you might need to “sudo apt-get python2.7” (I’m not sure, but probably “sudo apt-get install python” without the “2.7” will likely also install 2.7).

linuxdev, Thank you for your reply.

However, I have already installed python 2.7 and tried to install JetPack OS.
The SDK Manager tells me Jetson OS is successfully flashed to device, but it is not.

Flash and package install are separate steps, so the wording is a bit misleading. Apparently SDKM only flashed and did not install extra packages. You can then tell SDKM to install packages, but not flash. Looks like actual flash was successful.

Simply run again, but leave the TX2 fully booted without using recovery mode. Keep the micro-B USB cable connected, and uncheck every operation except for adding packages to the Jetson side. Looks like host side already has the packages added.

You may need to log in via GUI once to the TX2 if it did not create an account (and the account would be needed for packages to be installed).

Problem solved.

Thanks for your help.
Have a nice day!