How to make Jetson nano enter deep sleep and how to wake it up?

Would you please let me know how can I make Jetson nano enter deep sleep mode to save the power and how to wake up it from the deep sleep mode?
Thanks

Hello @changwen.xie
This guide says that:

Deep Sleep Mode

You can initiate deep sleep from the user space with this command if the systemd init system is in use:

$ sudo systemctl suspend

Alternatively, you can use this:

$ sudo bash -c “echo mem > /sys/power/state”

The first method of entering deep sleep is preferred because it cooperates better with systemd, which maintains the Linux runlevel. Use the second method if your system is not running systemd.

Awaking The Device

The system can be awakened from deep sleep by common wake sources available on Jetson platforms:

Wake Source Usage
Power button Press and release the power button on the Jetson device. If the power button is not available, connect then disconnect the power button pin and ground.
RTC alarm Before entering low power state, program the RTC alarm with the command: $ sudo bash -c "echo date ‘+%s’ -d ‘+ 10 seconds’ > /sys/class/rtc/rtc0/wakealarm"
Micro USB cable hotplug Connect or disconnect a micro-USB cable to the USB micro-B port for flashing the device.
USB remote wakeup Press any key on a USB keyboard connected to the device. Note that Linux does not support a USB mouse as a wake source.
Wake on LAN On another machine on the same LAN, enter: $ sudo etherwake -i <interface> <MAC_address_of_target>
SD card detection Insert or remove SD card.

https://docs.nvidia.com/jetson/l4t/Tegra%20Linux%20Driver%20Package%20Development%20Guide/power_management_nano.html#wwpID0E0QP0HA

Regards

Hi
Thank you for your kind reply.
I tried this command:
$ sudo systemctl suspend
it says: “Failed to suspend system via logind: Sleep verb not supported”

I also tried this sudo bash -c “echo mem > /sys/power/state”
It failed as
“bash: line 0: echo: write error: Invalid argument”

What can I do for it?
Thanks

when I use the the command below:
echo freeze > /sys/power/state
It may enter sleep mode. I tried to wake up by press the keyboard, it can wake up. But after wake up, the WIFI access point does not work any more.
What can I do for it?
Thanks

I found this solution https://askubuntu.com/a/761220

Hope it works

I tried the command:

sudo systemctl restart network-manager.service

It restored the WIFI network connection, but the Access point I set before went into deep sleep.
How can I solve it?
Thanks