How to put Jetson TX2 NX Dev Kit in recovery mode

I am reaching out to request your assistance with entering recovery mode on my Waveshare Jetson TX2 NX Development Kit. Despite multiple attempts, I have been unable to successfully enter recovery mode.

The device is detected by lsusb as 0955:7020 NVIDIA Corp. L4T (Linux for Tegra) running on Tegra, indicating it is not in recovery mode.

I need to know which two pins to connect my jumper wires to in order to put the Jetson device in recovery mode. The 40 pins are laid out as such on the back of the device:
3v3 5v 3 5v 5 GND 7 8 GND 10 11 12 13 GND 15 16 3V3 18 19 GND 21 22 23 24 GND 26 27 2 29 GND 31 32 33 GND 35 36 37 38 GND 40
I have tried several options, but none have worked for me. I would greatly appreciate your guidance on identifying the correct pins to short-circuit for recovery mode.

The recovery mode has nothing to do with the 40pins. It needs to use the jumper on the J14.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.