How to remove the gestures from chromium while running in Kiosk mode

Hello everyone,

I have been trying to run a app in chromium and i want to run it in Kiosk mode but when i swipe from top, left and right it is exiting from kiosk mode, how do i disable these gestures while chromium is in kiosk mode.

What i have tried till now.
Disabling gnome gestures using Disable Gestures.
Disabling few features under chrome://flags/

But nothing worked for me.

Is it possible to remove the GUI entirely and run only chromium or firefox?

UPDATE: I gave up on using chrome/firefox. I installed WPE WebKit for Mir Kiosk on Jetson and i followed THIS to enable DRM.

WPE Webkit works only after i do sudo modprobe nvidia-drm modeset=1 but right now iā€™m doing it after each boot is there any way i can keep it even after rebooting the Jetson.

@kayccc @WayneWWW @DaneLLL can someone help me with this?

Thanks

Hi,
We have a sample demonstrating DRM:
Jetson Linux API Reference: 08_video_dec_drm (Direct Rendering Manager) | NVIDIA Docs

As a quick solution, you can enable rc.local to run the commands in booting:
Jetson AGX Orin FAQ

Q: How to autorun an app or commands at startup?

A clearer solution is to re-flash the system to non-desktop rootfs:
Root File System ā€” Jetson Linux Developer Guide documentation

Hi @DaneLLL,

I gave up on Mir Kiosk since the CPU consumption is very High.

I found a way to freeze the window uisng another extension i found Disable all gestures - GNOME Shell Extensions. This helps in disabling demaximizing window etc.

1 Like