How to setting static router permanent for Xavier

Hi guys, I doing with the Jetson Xavier AGX. My purpose is transmit the multicast data from another computer with the same Lan network and in Xavier i have a listener C++ program which can receive all the data incoming to the Multicast address. However, the jetson cannot receive any data package and it’s show the error “no such device” and then “too many open file”. After several seraching, i had figured out the problem by run this command “sudo route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0” then now I can see the data coming to jetson. The problem is, whenever i reboot the Jetson, the above command was not effect anymore and i have to re-run the $sudo … again. How can I make the jetson to auto run the above command everytime I reboot.

Don’t know if this will work, but it is possibly a simple solution: Use “sudo nm-connection-editor” (if you don’t have this, then “sudo apt-get install network-manager-gnome”).

Notice when you open the application that the different network end points are listed, e.g., “Ethernet” with “Wired connection 1”, or “Bridge”, with “l4tbr0”. You are using the first ethernet connection, so click on that. Then click on the “gear” icon in the lower left for configure. I am assuming IPv4, so click the tab for “IPv4 Settings”. Note that at the bottom there are “Routes…”. You wouldn’t want to change the other addresses, but you would want to add routes. Maybe you can add this route here and hit save, then exit and it might stick.

Hi, Thank you for your reply. Because i use the ssh to Xavier so your method is not useful for me. Here is my solution:
Create the file /etc/network/if-up.d/route with:

#!/bin/sh
route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0

and make it executable :

chmod +x /etc/network/if-up.d/route