How to update my tensorrt version on my Jetson AGX board?

Description

Unable to upgrade the Tensorrt version on my Jetson AGX

Environment

TensorRT Version : 7.1.3-1
GPU Type : Volta GPU
Nvidia Driver Version : 32.5.1
CUDA Version : cuda 10.2
CUDNN Version : 8.0.0.180
Operating System + Version : Ubuntu 18.02
Python Version (if applicable) : Python 3.6
TensorFlow Version (if applicable) : 1.15.5+nv21.6

Steps To Reproduce

  • I tried to upgrade my tensorrt from 7.x.x version to 8.x.x version using debian installation on my jetson AGX using the below tutorial.
    Installation Guide :: NVIDIA Deep Learning TensorRT Documentation
  • Some say install using sdkmanager from the host machine. I tried installing using the sdkmanager jetpack version 4.6.1, but unfortunately that didn’t upgrade my tensorrt.
  • If I download a .deb file for amd64 machine, then should I run that on the host PC? but how will that install/upgrade the tensorrt on my Jetson AGX. Note: There is no arm64 .deb file for Ubuntu 18.04 and Cuda 10.2 . So how am supposed to install it directly on my Jetson AGX?
  • Some say you can not update directly on Jetson board, it is only possible through Jetpack.
  • Nvidia Team, can you guys please make a bit more clearer on your documentation and please help.

Hi,

The simplest way to upgrade TensorRT is to use our OTA feature.
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/updating_jetson_and_host.html

Please upgrade the device to r32.6.1 first.
And then install the TensorRT package with the following command.

$ sudo apt update
$ sudo apt install nvidia-tensorrt

Thanks.