I am getting below error on RHEL-5.9 (2.6.18-348.el5) and MLNX_OFED_LINUX-1.5.3-4.0.42,

mlx4: There is a mismatch between the kernel and the userspace libraries: Kernel does not support XRC. Exiting.

Please suggest here.

Thanks,

Rupesh.

Hi,

In my case, I disable ib_srp krenel module and restarted the servers. So I am not getting this error now.

I didn’t get the exact cause but it worked.

Thanks,

Rupesh.

Hi yairi,

I am using MLNX_OFED_LINUX-1.5.3-4.0.42, and RHEL-5.9 (kernel version:2.6.18-348.el5) .

Thanks.

Thanks yairi… I will try this…

Rupesh.

Hi,

The XRC compatibility issue is known to be related to some of the older versions of OFED when XRC support changed in the kernel itself.

what version of OFED are you working with? What is your OS and kernel version? is it possible to update the OFED?

I think that with RHEL5.XXX this is far as you can go with OFED.

see if this procedure works for you (got this from a friend ;-)

  1. Download the following tree - http://git.openfabrics.org/git?p=~shefty/libibverbs.git;a=tree;h=refs/heads/xrc;hb=xrc http://git.openfabrics.org/git?p=~shefty/libibverbs.git%3Ba=tree%3Bh=refs/heads/xrc%3Bhb=xrc

  2. Unpack and compile as follows: # tar zxvf libibverbs-xrc-ea0fdc0.tar.gz # cd libibverbs-xrc-ea0fdc0 # ./autogen.sh # ./configure --prefix=/usr --libdir=/usr/lib64 --sysconfdir=/etc --disable-shave # make # make install

other then this (e.g. if it doesn’t work), your next option is to work with the kernel inbox driver (the one that is shipped with the kernel itself)

Cheers