I am getting the infamous issue where my notebook can't wake up from sleep after updating my driver

I have ubuntu 16.04 with the driver 340 and it was a sweat to install it but it worked well for a few years. Last week I realized there were now updates in the apt package manager on my upgraded 20.04 ubuntu and decided to download it. But now it won’t wake up after suspension. I tried all sorts of solutions like putting all sorts of things in my grub file. Purging and reinstalling to no avail. I even tried to go back to nouveau but then I can’t even start the gui outside recovery mode.
I know the driver is installed but the command nvidia-smi won’t work no matter what.

Sep 27 10:57:41 inspiron-3542 kernel: [ 0.038632] You have booted with nomode
set. This means your GPU drivers are DISABLED
Sep 27 10:57:41 inspiron-3542 kernel: [ 0.038633] Any video related functionality will be severely degraded, and you may not even be able to suspend the system properly

I just found this in the logs. How do I fix it?

What is your GPU ?
If the GPUs support new drivers you need remove current driver and reinstall , but before see if is possible enable nouveau driver to avoid a black screen when restarting.

My gpu is 820M.
I tried enabling nouveau but I get the black screen when I reboot…

Here i use 20.04.3 with gt 640 and some times the machine not wake up from suspend. The machine is power on, but in black screen.

I had configured the power manage to suspend in 10 minutes and now the machine is returning from suspend mode.

Try reinstall the OS if is more simple for you.
Your GPU is good for a notebook … remember to configure nvidia-settings to limit clock maximum frequency to avoid high temperature not being above 60C and adding a command line in your startup OS.

Now exactly the machine had done suspend mode, but only disks and display was power off at point that trying go back from suspend mode not is possible.
That happen in Ubuntu 20.04.3 and in Ubuntu 21.04 not happen that issue.

So updating to 21.04 solved the issue?

I had used Ubuntu 21.04 for more than 3 months resume without problems.
Try use 21.04