I need to upgrade the firmware in a Mellanox Card MT27800, they are installed in a ESXi running vpshere 6.7 u3 i tried to install the mft tool but i have this error L 'Could not find a trusted signer: certificate has expired'),

i have other hosts with 6.5 version i dont receive any error, anyone knows if the mfs and nmst tool have some compatibility issue with 6.7 U3? i downloaded the latest version , i tried to force the installation but same error, files :nmst- and mft-


To workaround this issue apply the following:

  • Move the ESX machine to community-support

esxcli software acceptance set --level=CommunitySupport

  • Install the bundle with no-sign-check

esxcli software vib install -d <vib_file> --no-sig-check

  • Set back PartnerSupported

esxcli software acceptance set --level=PartnerSupported



above suggestion fails with secure-boot

[root@esx:~] esxcli software acceptance set --level=CommunitySupport

Invalid data constraint for parameter ‘level’. Expected a single value from the set [VMwareCertified, VMwareAccepted, PartnerSupported, CommunitySupported] got ‘CommunitySupport’

[root@esx:~] esxcli software acceptance set --level=CommunitySupported


Secure Boot enabled: Cannot change acceptance level to community.

Please refer to the log file for more details.

This post is a year ago, so this is probably not very helpful, but the issue was that it’s CommunitySupport but it should be CommunitySupported, like so:

esxcli software acceptance set --level=CommunitySupported

The full steps are available here: