I try dragging a USD exported from Blender, and I get 'Asset has no default prim'

I can open the USD file from Blender and my prop looks correct.

Is there a way to set the Default Prim when I export from Blender?


If I should post this in Blender topic let me know.

Thank you

Hello @DataJuggler! I’m asking the team if they’ve run into this issue. I’ll post back when I have more information!

Thank you.

Hi there,

There are settings for the default prim under Stage Options in the USD Exporter-- did these not work for you?

image

Are those options in Blender?

This is all I see in Blender when I go to export USD.

Where is the Stage Options you mentioned?

Thanks

Those options are part of the Blender version you can install through the Omniverse launcher. The official Blender Foundation release has fewer options and I do not believe it has an export setting for default prim.

I had the Omniverse version on, and one of my add-ons complained so I went to main version.

I will put OV version back on.

Will that feature be adopted by main Blender app?

Thanks

The goal is to port all features from the USD Branch to mainline if possible, but the process takes time. This is one of the reasons we have the Alpha in the launcher-- it provides faster access to features that do not yet exist outside.

Thanks. Just installed it.

That worked.

hi, thanks for your help it worked for me too.

https://shareit.onl/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.