Import Error: undefined symbol: png_riffle_palette_neon


I am currently working on a program that does real-time facial recognition using a raspberry pi v2 camera module. I was using OpenCV, dlib-19.17, and face_recognition. The program was working but I was having latency issues and read that I could update dlib-19.17 to dlib-19.21 to help achieve better results. I updated but now when I try to run the program I get an import error: undefined symbol: png_riffle_palette_neon.

I’ve tried looking online on how to resolve this error but haven’t been able to find much regarding the issue. Has anyone else encountered this error and has been able to resolve it?

Edit: I am using Jetson Nano 2GB and currently have JetPack 4.6 installed.


It looks like you need to install a particular libpng-dev version.
Could you share how do you install the dlib-19.21 first?

Please also try the following command to see if it helps.

$ sudo apt-get install libpng-dev


Hi @AastaLLL ,

I also got this issue.
After trying “sudo apt-get install libpng-dev”, it still not work.

The following steps are how I installed dlib (GPU):

dowload repo:
cd dlib-master
mkdir build
cd build/
cmake ..
cmake --build .
cd ..
sudo python3 install

Jetpack 4.6
Numpy 1.19.4

I used the process described by another user in a different forum:


We try the installation commands on JetPack 4.6.
And it can work correctly without issue.

$ python3
Python 3.6.9 (default, Jan 26 2021, 15:33:00)
[GCC 8.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import dlib

Do you meet the error when importing dlib?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.