In Deepstream-6.4 multiple streammux is not working

Please provide complete information as applicable to your setup.

**• Hardware Platform GPU -----------> 3070 laptop
**• DeepStream Version --------------> 6.4
• TensorRT Version -----------> 8.6
**• NVIDIA GPU Driver Version ------> 535

Hi Nvidia ,

Greetings of the day ! I am running 6.4 samples docker image(6.4-samples-multiarch) and I try to run parallel inference with multiple streammux But It’s not working ! My Parallel pipeline written in python but the architecture is same as c++ sample. For me in 6.1.1 with new streammux is working every branch but 6.4 is not working !

In deepstream_parallel_inference_app, we did not test new streammux because it will to do scaling or conversion. could you share the whole media pipeline with new streammux? did you try C sample with new streammux in DS6.4?

even for old streammux also It’s not working. My question is what does it change from 6.1.1 to 6.2 ? Coz 6.1.1 with new streammux everything is working fine but from 6.2 onwards it’s not working anywhere the things is It’s not calling second branch only 1st branch it’s calling . If you elaborate a little then I can figure it out where I might making mistake and I am attaching my pipeline picture here You can look into it and share If I need to change any element …

please refer to the test on Nov 30 in this link. the app worked normally in DS6.2 docker. about "even for old streammux also It’s not working. ", could you use deepstream_parallel_inference_app to reproduce this issue? Thanks!

@fanzh I show the topic and the whole conversation But I did not find any solution ! Can you share me Deepstream parallel inference app pipeline picture ? and If you notice your topic ans and our pipeline is same and the problem is only 1st branch is calling … Now my question is 6.1.1 It’s working fine but 6.2 onwards it’s calling only one branch. I am asking is there any changes streammux ?

in the readme. there are many pipeline pictures, if using different cfg. bodypose_yolo cfg includes two branches, the path is tritonclient/sample/configs/apps/bodypose_yolo/source4_1080p_dec_parallel_infer.yml. its pipeline is 2branch.zip (883.9 KB). in my last comment, pipeline.zip only include one branch.

it is hard to say which modification will affect your custom code because there are many modifications in DS6.2. I test two branches cfg bodypose_yolo. the app worked well on DS6.2, please refer to log6.2-twobranch.txt (53.5 KB) and pipeline 2branch.zip. currently we suggest simplifying deepstream_parallel_inference_app code to reproduce the issue.

Can you share with me the pipeline picture then I can check how difference from my pipeline and try to debug it properly and make it done. or you can check my pipeline and share me some feedback where might my mistake !

please refer to 2branch.zip in my last comment for the pipeline picture.
from your pipeline, you an do the following modifications.

  1. remove the second nvstreamdemux in each branch.
  2. line the first tee to nvmetamux, and set it to active_pad. metamux will merge other two branches 's meta to this branch.

Second Demux I am using for getting each camera pad and I can get the detection value and others stuff I can’t remove that ! Do You think that is the problem ?
*** Same pipeline is working in Deepstream-6.1.1 with same element and all code same !
I would like to understand what element is the bottleneck for us and blocking our pipeline flow !!!

you can insert the second Demux after metamux. please refer to the pipeline 2branch.zip.
please refer to my last two comments. we suggest developing based on our sample. you can simplify the pipeline to narrow down this issue. for example, removing tracker, the second demux, using fakesink.

Okey Let me do what you have said, get back to you

As you said I tried like that ! But I am getting
“”“”“”"
(MainThread:59998): GStreamer-WARNING **: 05:18:31.821: …/gst/gstpad.c:5337:store_sticky_event:<Cam_streammux------>demux :src_0> Sticky event misordering, got ‘segment’ before ‘stream-start’

(MainThread:59998): GStreamer-WARNING **: 05:18:31.821: …/gst/gstpad.c:5337:store_sticky_event: cam001:src> Sticky event misordering, got ‘segment’ before ‘stream-start’
0:00:05.144819351 59998 0x7fc894000d80 FIXME basesink gstbasesink.c:3395:gst_base_sink_default_event: stream-start event without group-id. Consider implementing group-id handling in the upstream elements

(MainThread:59998): GStreamer-WARNING **: 05:18:31.821: …/gst/gstpad.c:5337:store_sticky_event:capsfilter-paddedcam001:sink Sticky event misordering, got ‘segment’ before ‘stream-start’

(MainThread:59998): GStreamer-WARNING **: 05:18:31.821: …/gst/gstpad.c:5337:store_sticky_event: cam001:sink> Sticky event misordering, got ‘segment’ before ‘stream-start’
0:00:05.157309783 59998 0x7fc894001200 FIXME aggregator gstaggregator.c:1410:gst_aggregator_aggregate_func: Subclass should call gst_aggregator_selected_samples() from its aggregate implementation.
“”“”“”

This warning and got able to see any data what I able to see previously !
Could you tell How I can solve this ?
I have attached my pipeline picture top ! Let me know If I made any mistake ! I am taking the pad 2nd caps-filter

There is no update from you for a period, assuming this is not an issue any more. Hence we are closing this topic. If need further support, please open a new one. Thanks.

what do you want to solve? can the pipeline run well? please refer to sample pipeline 2branch.zip, please line the first tee to nvmetamux, and set it to active_pad. metamux will merge other two branches 's meta to this branch.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.