In Isaac sim docker container, how can I CACHE:ON?

Hi I installed Isaac sim docker from “isaac-sim.docker.gui.sh” file below…

isaac-sim.docker.gui.sh (1.5 KB)

so in that container terminal
I tried below command and gui screen is loaded.
$ ./isaac-sim.sh

However , as you can see in right upper side, the CACHE is OFF with red color text.

I want to CAHE:ON to use jupyter notebook to step-by-stepy run my ipynb code below.

doyoung.ipynb (1.7 MB)

when I run my doyoung.ipynb code in jupyter notebook, the code only run in headless mode I think. because there is no gui changes.

As I know, jupyter notebook live syncs to the same USD so that changes are reflected in another Isaac Sim process launched through the terminal or the launcher. But, in my situation I can not synchronize between jupyter notebook and isaac sim like this below tutorial video in Nvidia document. so I guess this CACHE:OFF causes the problem.

thank you!

Hi. Do you have Cache and Nucleus installed from the Launcher on the host that is running that docker container?

Hello! Thank you for reply… Im so sorry but I already installed Cache and Nucleus in my local host pc but I don’t know how to connect those with my docker container. can I get reference document or guidance from you ?

And, also as I found some documents, Nucleus and Cache is no availabe in Isaac Sim container so there is no way to use Cache:On … right??


https://docs.omniverse.nvidia.com/app_isaacsim/app_isaacsim/install_faq.html

@Sheikh_Dawood hi… Im’ so sorry to bother you but can you reply my qustion…?

Hi, apologies for the late reply.
Cache and Nucleus is no longer included in the Isaac Sim container. You can install them from any Workstation with Omniverse Launcher installed.
Please note that this Cache is not the same as the cache path in the container. The cache in the container is a shader cache while the Cache icon in Isaac Sim is for the Nucleus Cache which only works with the Workstation version of Isaac Sim.
However, you may run Isaac Sim on a container where he host have Cache and Nucleus setup locally and that icon may turn green.

I have the same question as @user132705 .

I have Cache and Nucleus setup locally on the host pc, which also contains the container as you described. However, the icon of the Isaac Sim within the container still does not turn green (the icon of the native Isaac Sim app turns green though). Is there a specific setting I need to make to make the Isaac Sim (in the container) connect to the Cache running on the host PC?

It still doesn’t turn green with Isaac Sim 2023.1.0.

Hi. I’m afraid the Cache On icon is not supported in a container. It should be green when running Isaac Sim headless from the Launcher.

I understand, thanks a lot!

1 Like

Is there a solution for this problem? I’m running into the same issue.

If there’s no solution for turning on cash in isaac sim docker container, any bad consequences for caching docker container of isaac sim?