Isaac on Docker: Unable to detect Omniverse Cache Server. Consider installing it for better IO performance

Apparently the 4.0.0 container no longer has built-in cache server. I am getting the following:

Isaac on Docker: Unable to detect Omniverse Cache Server. Consider installing it for better IO performance.

How to configure the container so it can use either localhost or a remote computer as cache?

cc @pcallender @jiehanw @dennis.lynch @hclever

Actually this has always been the case but the warning didn’t appear on 2023.1.1. Should I be worried? I do have the cache installed but no local nucleus. Maybe that is the problem?

Actually installing local nucleus worked for a single run, but not for more… The log appears again.

Looks like the cache errors out
image

Error fixed the log message is still there.

and no cache is being used… so my question is again: how to get the docker container to use the cache?

Moving to IsaacSim forum where we can get some of the IsaacSim team’s guidance. @ahaidu Any thoughts?

Hi, the Cache server is meant to be used with Nucleus only and for the Workstation.

When using the docker container, the default assets path is from the Cloud. Cache and Nucleus is not needed in this case.

To set the assets path, use this:
--/persistent/isaac/asset_root/default="http://omniverse-content-production.s3-us-west-2.amazonaws.com/Assets/Isaac/4.0"

What if I have my assets on a different local computer hosting the nucleus service? Will it cache them or not? We use a mixture of cloud (nvidia) and private assets.

For enterprise use, the is a Cache server that can be installed on-prem to cache assets from multiple external and internal Nucleus.

For workstation use, You can install both the Cache server and Nucleus on the on-prem workstation. The Cloud assets will be cached on that workstation.

The Kit and Isaac Sim app itself have some kind of cache folder but it is not user configurable. Some caching is still done locally to the container.

What I am trying to do is to cache for workstation docker container. I have both nucleus and cache installed on the docker host, but the container “doesn’t see them”, as per logs.

I assume you are referring to caching USD assets. Have you tried running the container with the default mounts and pull the assets the second time to see if the assets are cached on the Nucleus side?

I think that error can be ignore because it does not detect a Cache installed on the docker. This was meant for the workstation App only.
The default assets path for the container is a remote Nucleus or Cloud and the local mounts is used for data caching.

Yes I am using the mounted container folders. I am not seeing any speed difference between first run start and every other run start, that’s why I raised the issue. I used to be able to observe a big difference in the previous version 2023.1.1.