Initial installation headless mode with MacOS

Hi,
I followed the steps here: getting started with Jetson Nano I wrote the image to the SD card then flashed it. Everything went smoothly until I had to Locate the tty device.
The instructions say to run this command:

~$ ls /dev/cu.usbmodem*

but I find no matches:

zsh: no matches found: /dev/cu.usbmodem*

I am using the DC power supply, and the micro usb to USB-A cable to connect from the jetson to my MacBook Air. Since MacBook Air only has a USB-c port I have an adapter to USB-A. Could this be causing the issue?

I used the adaptor to insert the SD card and that worked fine. Please help I spent a lot of money hoping I could work on some cool projects! I purchased a used Jetson Nano, so this is most likely not the first installation, I’m wondering if that is the issue since oem-config is designed to launch on first boot.

Hi,

USC-C to USB-A cable to connect from the jetson to my MacBook Air. Since MacBook Air only has a USB-c port I have an adapter to USB-A. Could this be causing the issue?

Which port is connected on nano side? The tty console port is from the micro usb port on nano devkit but not the type A port on usb hub.

Hi thanks for replying! yes the usb-c (Micro USB) side is connected to the nano and the other side, the usb-A is connected to the adapter which is connected to my MacBook Air

Is there also a adapter on the nano side? Because we don’t have a type C port on nano devkit…

No, it’s connected to the micro-usb. Number 3 on this image I thought micro-usb and usb-c mean the same thing? Apologies if they are different. The power supply is from #8, the green light turns on when plugged in

Do you see anything if checking below nodes?

ls /dev/cu.*

If nothing, could you keep the cable connected and reboot your Air and check again?

I only see my AirPods and beats. I tried rebooting my machine too and same output.

$ ls /dev/cu.*

/dev/cu.Bluetooth-Incoming-Port
/dev/cu.GymBrosBeatsStudio3-Wir-2
/dev/cu.GymBrosBeatsStudio3-SPP
/dev/cu.RosasAirPods-WirelessiAP-5

this article mentions the USB-c to USB-A adapter does not work. Is there any other way to boot this headless? I don’t have a monitor mouse and screen… otherwise I will just have to return it :(

Hi,

What is the version of your macOS?

it’s macOS Big Sur version 11.11

Will it work if I try a USB-c to Micro USB connection? USB-c from my MacBook Air to Micro USB to the nano instead of using the adapter?

I know the cable must be able to transfer data… how can I make sure I buy one that does?

Is this the new Macbook M1?

No, it’s not

I try to use USB device mode on my Macbook Pro Big Sur 11.2. It seems to be ok.
I use anker microUSB cable and anker USB C hub.
Headless mode need a good quality usb cable and hub.

ls /dev/cu.

**cu.Bluetooth-Incoming-Port** % **cu.BoseRevolveSoundLink-SP** % **cu.usbmodem14150190005503**

For headless setup, I usually use this type of serial console. It does not seem to need additional driver on my Macbook Air M1 Big Sur. just run this and you can connect to the console

screen /dev/cu.usbserial-… 115200

HI
I am using jetson nano for the first time, have followed the module Getting Started With Jetson Nano Developer Kit | NVIDIA Developer and successfully logged into the device and created the swap. I got the wifi module installed and don’t have ethernet. after that I’m not clear if I have to follow the headless mode or is it a separate way of booting up? . I am unable to really understand how to get the docker running.

kindly give me a direction to catch so that i can proceed.