install chrome

hi.
How to install Chrome browser properly via command line?
The chrome.deb file is not installed when I run the internet chrome homepage download.

or
I want to connect to ‘Jetson tx1’ via ‘DHCP’ and control ‘Jetson tx1’ remotely like ‘Chrome Remote Desktop’.

“chromium-browser” is already installed by default, but has optional plug-ins. You might explore this:

apt search chromium
apt search chrome

FYI, DHCP sets up ethernet automatically via a router…this won’t have any effect on the Jetson other than the wired ethernet working. So far as control goes I am not familiar with chrome remote desktop. Is there a particular plugin or package you can describe for what you are wanting to do?

Like ‘teamviewer’ or ‘Chrome Remote Desktop’, I want to remotely access and control jetson tx1.
‘remotely access and control’ means I will access jetson tx1 from another computer remotely and use it. Also it should use DHCP connection.

p.s
I am not a native speaker. Please understand that English is not proficient.
I am also a perfect beginner. I always appreciate your help. thank you so much

I found this URL to be of interest:
https://support.google.com/chrome/answer/1649523?hl=en&vid=0-524962312101-1501857790508

With the package “chromium-browser” installed on the Jetson I was able to put this address into chromium:
chrome://apps

As a result I was able to go to “web store” (you will probably have to use your gmail login account). Then search for app “remote desktop”. This allows installing chrome remote desktop. It seems that this is all done through google and the app runs within chrome, so there is no need for directly installing any application on the system. I did not try to use the service after that point, so I have not tested further.

In my case I am using a private gigabit ethernet, and using this application would have required my Jetson to go over the internet to google, then back again over the internet to my desktop PC. Ironically, my desktop PC is also the router to the Jetson. Performance would suffer. Had the other end of the connection been to a remote internet user this would have been a very good feature. Over private networks this seems to suffer and not take advantage of the local network, but perhaps I am wrong since I did not test.

Hi @linuxdev,

But this Chrome-remote-desktop is for amd64, and Jetson Xaiver and nano is arm64, It wouldnt work right… Is there anyway to make it run here.

The short answer, so far as I have checked: If you go to “chrome://apps”, sign in to Google, and search for “remote desktop”, then you should be able to add this via the browser. The browser will correctly add the architecture if it exists. I did install to both PC and a Jetson NX (very similar to the TX1 if you have a recent L4T release), but did not test it. Had I tried to add this via the “apt-get” mechanism, then this would have failed since it is chromium-browser which installs the mechanism, and not the system as a whole. If you want to know more about how/why it could/should/wouldn’t work, keep reading.

In terms of cross architecture sharing I can only give you an idea of how I *think( it would work (or not) as a way of thinking about remote protocols/desktops.

Often (just in general, not necessarily with chromium-browser), with a remote desktop protocol, the communications over the network will not care about architecture. The application running on the PC or Jetson will care unless the application is entirely an interpreted script language. It is unlikely that an entire remote desktop would have the ability to do its job purely as a script, but if you were displaying something like the browser itself, then maybe it could do this using JavaScript/ECMAScript (architecture independent scripting), although I doubt desktop sharing would be purely a script (even a scripted tool probably has some binary content in the form of some sort of plug-in). On the other hand, if the browser allows adding a program, then you already know the binary part of the content is native to the architecture where needed.

Anything designed for amd64 would fail to install/run on arm64. Anything amd64 operating from amd64, but talking to arm64 would likely succeed if the arm64 side has arm64 binaries (each end would have the proper software for talking to an architecture agnostic protocol).

Basically, you should try it out and see if it works, but if you are required to install an amd64 package on arm64, then don’t even try. Google store will know what architecture you are using if you install via the “chrome://apps”, and incorrect architectures won’t even show up.

Hi @linuxdev

Thank you so much for such a detailed explanation.

I’m using Xavier AgX, and I’m very curious how it got installed in your NX, because the architecture is same ARM64.

I can get the chrome remote desktop extension but when I go to chrome-remote-desktop/access, I click the download button but it never gets downloaded. And I also went to the official chrome remote desktop support, I can see only amd64 support, hence I too confirmed yes it is why the download or install never starts from that remote desktop window ( set up remote desktop)

But from what you told me, I’m very curious, I’ll give a try from that link and I’ll let you know. If it gets installed then everything will be good.

I got a crd package from AUR forum, thinking Xavier AgX architecture is Aarch64 but that also didn’t work, failed to install as the package was installing amd64 build.

I already had chromium-browser installed. By navigating within chromium-browser to the URL:
chrome://apps
…then logging in to Google store, I am able to search for various apps. I searched for “remote desktop”, saw the chromium remote app, and told it to install. Chromium did the rest.

EDIT: Note that I suppose it is possible that some setting related to scripting security could block install.

I suppose you installed only the extension right, I guess you have not further went to install the actual package.

This is what you installed right ? If yes, then for me also it installs this extension. But after that, it leads you to this setup window, where it fails @linuxdev

And the above snap is the main download, here it never gets downloaded, and doesn’t fail or show error either.

You are correct. I did not attempt further setup (mostly because I am not familiar with this remote desktop and have never used it before). What is the actual package, where to get it, and does it go on both ends, or can this extra application be installed at just one side of the connection?

Hi @linuxdev,

Its the most simplest form of remote desktop I have ever seen,
I’ll share a link, just have a read,
https://support.google.com/chromebook/answer/1649523?co=GENIE.Platform%3DAndroid&hl=en
So, here basically, you got to login, get that extension, which you probably have, then go to https://remotedesktop.google.com/access, and just follow the steps to create (any device) here Xavier into a remote device, and then you login to chrome on the other side of your system, and start accesing your remote device through https://remotedesktop.google.com/access, you can see all your devices.

But as Xavier AGX or any jetson doesnt support their package, it isnt installing,
By far the most easiest way to remote desktop but ARM64 incompatibility issues failed to make it worth it.

I let it run for quite some time, but the “Set up remote access” never completes (despite being logged in to Google). I suspect the server providing the download should be giving an error about no download being available for that architecture (arm64), but simply spins without completing. Since there is no error message, and since the download file is on Google’s server, I have no way to tell what is really going wrong (it doesn’t appear that the Jetson has any control over this).

If there is a support forum for TeamViewer, then I would ask them if there is a way to get and manually install the “Set up remote access” download for arm64/aarch64/ARMv8-a (Ubuntu 18.04) without going through the chromium-browser’s mechanism. Or to at least somehow get a log as to why the setup is infinitely spinning instead of completing.

Hi @linuxdev exactly you are right, maybe it is trying to find the file for this architecture but it should atleast fail or show some error, now that is sad to see.

We are talking about chrome remote desktop, https://support.google.com/chrome/community?hl=en, why don’t we post a question. I can post too but you could point the right technical aspects. @linuxdev Can we have our conversation esse where if possible. Because our conversation is totally irrelevant to nvidia and I don’t want any moderator to comment negative on this.

I would not say this is irrelevant to NVIDIA. Many people want to use the chromium remote desktop. The trick is that NVIDIA does not control the server performing the download which never completes. Everything being posted is quite relevant and useful, and is not something which would cause problems with moderators :)

The trick is that someone needs to ask the community forums for the chromium remote desktop software how to debug the download running infinitely and never completing when using Ubuntu 18.04 on arm64/aarch64/ARMv8-a. The question of “why would the download not provide an error, and also not actually download when working with Ubuntu 18.04 on arm64/aarch64/ARMv8-a” should trigger a discussion. I simply don’t know enough about it to debug.

1 Like

@linuxdev,
SOrry for the delayed reponse,

Sure, you are correct! Someone needs to ask the community forum for the CRD software in jetson, Hope this gets resolved asap and get support for it.

I also found many issues while installing Chrome Browser via Command line. I searched a lot about this topic and finally found a working solution after 2 days.
https://www.techsguide.com/how-to-install-chrome-browser-via-command-line/