Install JetPack L4T 3.1- Network Layout - Jetson TX2

Hi This is Jang

Host PC : 16.04 Ubuntu (not VM)
Target : Jetson TX2 (L4T 28.1)

I would like to install version 3.1 of ‘Jetpack’ on ‘Target’.

I’m installing and viewing following documents and videos:

http://docs.nvidia.com/jetpack-l4t/3.1/index.html#developertools/mobile/jetpack/l4t/3.1/jetpack_l4t_install.htm%3FTocPath%3D_____4

and

There is one question.

My Host PC is wire internet. but TX2 use wifi.

What should I choose between ‘Device accesses Internet via router/switch.’ and ‘Device a accesses Internet via host machine through setting up a new DHCP server configuration on host.’

There is no extra router, and the router is far from the PC.

I would be grateful if you could let me know what choice I should make.

what if I can not install the ‘Jetpack3.1’ with WiFi?

Hi jc.jang,

Is your host PC able to ping TX2?

How can I check Ping?

Do I need to set TX2 to recovery mode and connect them using micro-b & usb cable ?

Hi jc.jang,

If you want to use wifi for reflash whole BSP, this is not possible.

However, if you already installed BSP and just want to install cuda or anything else. It should be okay.

Which one are you going to do?

I already installed L4T 28.1 version.

and Now I want to instsall jetpack 3.1version

because I’m using jetpack3.0 version.

I want to update jetpack3.0 -> 3.1

Do you want to upgrade from rel-27.1 -> rel-28.1? If yes, wifi may not able to help. You need to prepare micro usb cable.

For updating BSP(kernel), reflash under recovery mode is needed and wifi is not supported under such case.

For updating only software stuff, like cuda, tensorRT, opencv, it does not need to enter recovery mode and wifi can work.

I already told you that I’m using L4T 28.1 version in my first post.

I want to install jetpack 3.1 version.

My Host PC is wire internet. but TX2 use wifi.

What should I choose between ‘Device accesses Internet via router/switch.’ and ‘Device a accesses Internet via host machine through setting up a new DHCP server configuration on host.’ ?

Sorry about that. Then back to my first comment, is your PC able to ping your tegra device IP?
Normally, we use ‘Device accesses Internet via router/switch.’

Yes my PC able to ping my tegra device IP

Then just select ‘Device accesses Internet via router/switch’

I know what your concern is. But I think it is fine to just select “Device accesses Internet via router/switch”

You should face one error after “Device accesses Internet via router/switch”. Please ignore this one and re-open jetpack again. Choose only what you want to install except flashing board. Then enter the wifi ip when jetpack asks your prompt of ip.

Thakn you I installed

Be sure your host has package ssh-askpass…else you may need to enter a password and it’ll never pop up:

sudo apt-get install ssh-askpass

…there are actually a few alternatives, see “apt search askpass”.

thank you

Hi WayneWWW

My host pc cannot ping TX2

host pc’s ip address is 175.209.49.xxx

TX2’s ip address is 192.168.0.xxx

so This error occurred.

Finished Flashing OS
Determining the IP address of target...
192.168.0.xxx

Waiting 30 seconds to make sure target is fully up
Host 192.168.0.105 not found in /home/jc/.ssh/known_hosts
/home/jc
Identity added: /home/jc/.ssh/id_rsa (/home/jc/.ssh/id_rsa)
scp -F /dev/null -o PubkeyAuthentication=no -o ConnectTimeout=30 -o StrictHostKeyChecking=no
/home/jc./ssh/id_rsa.pub nvidia@192.168.0.xxx:/home/nvidia/tmp.pub
host 192.168.0.105 port 22: Connection timed out

192.168.0.xxx is not a valid IP here. Are you still using the same network layout?

Some added information on “192.168.0.xxx”…

This would be from a private subnet issued by a router, and without the router, not able to access the real internet. Another computer connected to the same router could find this valid.

The “175.209.49.xxx” address is on a different subnet. Direct communications between two subnets is not normally possible unless you have a gateway to traverse the two subnets. Unless you have an expensive high end router, then the router won’t have this ability…if you do have such a router, then it would need to be explicitly told to do this.

Are the TX2 and PC connected to the same router?

thank you i installed jetpack