Install MX450 on Debian Bullseye/Bookworm - Dell Vostro 5510

I’m trying to install the nvidia drivers on a new Dell Vostro 5510 with Geforce MX450.

I’ve tried the oficial debian tutorial in NvidiaGraphicsDrivers - Debian Wiki

both nvidia-legacy-390xx-driver and nvidia-driver doesn’t work properly.

the onboard intell allways stay as the primary graphic card:

glxinfo|egrep “OpenGL vendor|OpenGL renderer”
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Xe Graphics (TGL GT2)

here is the nvidia-bug-report.log.gz (54.1 KB)

After 2 days trying I have no idea what to do now.

Please disable secure boot in bios.

done. I’ve disable the secure boot. but nothing change. anything else?

Please create a new nvidia-bug-report.log


nvidia-bug-report.log.gz (54.5 KB)

Secure boot is still enabled, dmesg:

secureboot: Secure boot enabled

after an BIOS update i figured out how to disable secure boot:

secureboot: Secure boot could not be determined (mode 0)

here is a new log file:

nvidia-bug-report.log.gz (53.9 KB)

Ok, the module is still not loading, please try loading it manually
sudo modprobe nvidia
and post any errors given.

I reboot the system and now I’ve no graphics mode…

but in a terminal the comand ‘sudo modprobe nvidia’ returns nothnig.

I take another bug report:
nvidia-bug-report.log.gz (320.9 KB)

PS: this is a fresh install. i just buy this notebook. if the easiest way could be a reinstallation, there are no problems.

For now I’m trying with bullseye, but I pretend to do an upgrade to testing version (Bookworm)

Please delete /etc/X11/xorg.conf
and add the nvidia driver to the initrd:

thank you man!! it works!

Please set kernel parameter
for anti-tear and extended prime functions.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.